about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2016-01-31 17:01:00 -0600
committerThomas Tuegel <ttuegel@gmail.com>2016-01-31 21:15:03 -0600
commit7ea3225ea47e214e8ba412803f60b1806b673739 (patch)
tree1d60f61d42f4790c86d25f3ae041a4e6b9f33d5d /pkgs/desktops
parent588c8499f75d1c1f1c5bd42ca509eee83a6cb15a (diff)
downloadnixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar.gz
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar.bz2
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar.lz
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar.xz
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.tar.zst
nixlib-7ea3225ea47e214e8ba412803f60b1806b673739.zip
kde5.breeze: use runtime outputs
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5.5/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/desktops/plasma-5.5/default.nix b/pkgs/desktops/plasma-5.5/default.nix
index ea1533af7571..384fa6f6d272 100644
--- a/pkgs/desktops/plasma-5.5/default.nix
+++ b/pkgs/desktops/plasma-5.5/default.nix
@@ -48,8 +48,11 @@ let
     breeze-qt4 = callPackage ./breeze-qt4.nix {};
     breeze-qt5 = callPackage ./breeze-qt5.nix {};
     breeze =
-      let version = (builtins.parseDrvName breeze-qt5.name).version;
-      in symlinkJoin "breeze-${version}" [ breeze-gtk breeze-qt4 breeze-qt5 ];
+      let
+        version = (builtins.parseDrvName breeze-qt5.name).version;
+      in
+        symlinkJoin "breeze-${version}"
+        (map (pkg: pkg.out or pkg) [ breeze-gtk breeze-qt4 breeze-qt5 ]);
     kde-cli-tools = callPackage ./kde-cli-tools.nix {};
     kde-gtk-config = callPackage ./kde-gtk-config {};
     kdecoration = callPackage ./kdecoration.nix {};