about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-13 14:33:08 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-13 20:19:01 +0200
commit783c40eb68bbbcb9cf6918255157ecab55eedb6e (patch)
treedfa66d131f7bee9666eec32e942dff3547552212 /pkgs/desktops
parentad824a6a30d346b1d9a2f7500858748445991436 (diff)
downloadnixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar.gz
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar.bz2
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar.lz
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar.xz
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.tar.zst
nixlib-783c40eb68bbbcb9cf6918255157ecab55eedb6e.zip
dbus: split into multiple outputs and fix referrers
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/e19/efl.nix2
-rw-r--r--pkgs/desktops/gnome-2/desktop/gnome-keyring/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.16/core/empathy/default.nix4
-rw-r--r--pkgs/desktops/gnome-3/3.16/core/gdm/3.16-wip/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.16/core/gnome-online-accounts/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.16/misc/gpaste/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.18/core/empathy/default.nix4
-rw-r--r--pkgs/desktops/gnome-3/3.18/core/gdm/3.16-wip/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.18/core/gnome-online-accounts/default.nix2
-rw-r--r--pkgs/desktops/gnome-3/3.18/misc/gpaste/default.nix2
-rw-r--r--pkgs/desktops/plasma-5.3/default.nix2
-rw-r--r--pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch2
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-workspace/0001-startkde-NixOS-patches.patch2
-rw-r--r--pkgs/desktops/plasma-5.4/plasma-workspace/default.nix5
14 files changed, 18 insertions, 17 deletions
diff --git a/pkgs/desktops/e19/efl.nix b/pkgs/desktops/e19/efl.nix
index 16c934b3b3af..3afb76dccf10 100644
--- a/pkgs/desktops/e19/efl.nix
+++ b/pkgs/desktops/e19/efl.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
     "--disable-tslib" "--with-systemdunitdir=$out/systemd/user"
     "ac_ct_CXX=foo" ];
 
-  NIX_CFLAGS_COMPILE = [ "-I${xorg.libXtst}" "-I${dbus_libs}/include/dbus-1.0" "-I${dbus_libs}/lib/dbus-1.0/include" ];
+  NIX_CFLAGS_COMPILE = [ "-I${xorg.libXtst}" "-I${dbus_libs.dev}/include/dbus-1.0" "-I${dbus_libs.lib}/lib/dbus-1.0/include" ];
 
   patches = [ ./efl-elua.patch ];
 
diff --git a/pkgs/desktops/gnome-2/desktop/gnome-keyring/default.nix b/pkgs/desktops/gnome-2/desktop/gnome-keyring/default.nix
index f31875bed91c..50f2cd081332 100644
--- a/pkgs/desktops/gnome-2/desktop/gnome-keyring/default.nix
+++ b/pkgs/desktops/gnome-2/desktop/gnome-keyring/default.nix
@@ -9,7 +9,7 @@ stdenv.mkDerivation {
     sha256 = "02r9gv3a4a705jf3h7c0bizn33c73wz0iw2500m7z291nrnmqkmj";
   };
   
-  buildInputs = [ dbus.libs libgcrypt pam python gtk GConf libgnome_keyring ];
+  buildInputs = [ dbus libgcrypt pam python gtk GConf libgnome_keyring ];
 
   propagatedBuildInputs = [ glib libtasn1 ];
 
diff --git a/pkgs/desktops/gnome-3/3.16/core/empathy/default.nix b/pkgs/desktops/gnome-3/3.16/core/empathy/default.nix
index 83f33fbc3c56..48b45f28522e 100644
--- a/pkgs/desktops/gnome-3/3.16/core/empathy/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/core/empathy/default.nix
@@ -36,8 +36,8 @@ stdenv.mkDerivation rec {
                   file libtool librsvg ];
 
   NIX_CFLAGS_COMPILE = [ "-I${dbus_glib.dev}/include/dbus-1.0"
-                         "-I${dbus_libs}/include/dbus-1.0"
-                         "-I${dbus_libs}/lib/dbus-1.0/include" ];
+                         "-I${dbus_libs.dev}/include/dbus-1.0"
+                         "-I${dbus_libs.lib}/lib/dbus-1.0/include" ];
 
   preFixup = ''
     for f in $out/bin/* $out/libexec/*; do
diff --git a/pkgs/desktops/gnome-3/3.16/core/gdm/3.16-wip/default.nix b/pkgs/desktops/gnome-3/3.16/core/gdm/3.16-wip/default.nix
index 51b67afb01fd..b0e9652a9c51 100644
--- a/pkgs/desktops/gnome-3/3.16/core/gdm/3.16-wip/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/core/gdm/3.16-wip/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   preConfigure = ''
     substituteInPlace ./configure --replace "/usr/bin/X" "${xorg.xorgserver}/bin/X"
     substituteInPlace daemon/gdm-simple-slave.c --replace 'BINDIR "/gnome-session' '"${gnome_session}/bin/gnome-session'
-    substituteInPlace daemon/gdm-launch-environment.c --replace 'BINDIR "/dbus-launch' '"${dbus.tools}/bin/dbus-launch'
+    substituteInPlace daemon/gdm-launch-environment.c --replace 'BINDIR "/dbus-launch' '"${dbus.dbus-launch}'
     substituteInPlace data/gdm.conf-custom.in --replace '#WaylandEnable=false' 'WaylandEnable=false'
     sed 's/#Enable=true/Enable=true/' -i data/gdm.conf-custom.in
  '';
diff --git a/pkgs/desktops/gnome-3/3.16/core/gnome-online-accounts/default.nix b/pkgs/desktops/gnome-3/3.16/core/gnome-online-accounts/default.nix
index 6cedbca61d70..8bb21feb54ab 100644
--- a/pkgs/desktops/gnome-3/3.16/core/gnome-online-accounts/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/core/gnome-online-accounts/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
     sha256 = "1mpzj6fc42hhx77lki8cdycgfj9gjrm611rh0wsaqam4qq2c9a9c";
   };
 
-  NIX_CFLAGS_COMPILE = "-I${dbus_glib.dev}/include/dbus-1.0 -I${dbus_libs}/include/dbus-1.0";
+  NIX_CFLAGS_COMPILE = "-I${dbus_glib.dev}/include/dbus-1.0 -I${dbus_libs.dev}/include/dbus-1.0";
 
   enableParallelBuilding = true;
 
diff --git a/pkgs/desktops/gnome-3/3.16/misc/gpaste/default.nix b/pkgs/desktops/gnome-3/3.16/misc/gpaste/default.nix
index 6563f7979700..0d6551216cf8 100644
--- a/pkgs/desktops/gnome-3/3.16/misc/gpaste/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/misc/gpaste/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [ intltool autoreconfHook pkgconfig vala glib
-                  gtk3 gnome3.gnome_control_center dbus.libs
+                  gtk3 gnome3.gnome_control_center dbus
                   clutter pango appstream-glib makeWrapper ];
 
   preConfigure = "intltoolize -f";
diff --git a/pkgs/desktops/gnome-3/3.18/core/empathy/default.nix b/pkgs/desktops/gnome-3/3.18/core/empathy/default.nix
index 83f33fbc3c56..48b45f28522e 100644
--- a/pkgs/desktops/gnome-3/3.18/core/empathy/default.nix
+++ b/pkgs/desktops/gnome-3/3.18/core/empathy/default.nix
@@ -36,8 +36,8 @@ stdenv.mkDerivation rec {
                   file libtool librsvg ];
 
   NIX_CFLAGS_COMPILE = [ "-I${dbus_glib.dev}/include/dbus-1.0"
-                         "-I${dbus_libs}/include/dbus-1.0"
-                         "-I${dbus_libs}/lib/dbus-1.0/include" ];
+                         "-I${dbus_libs.dev}/include/dbus-1.0"
+                         "-I${dbus_libs.lib}/lib/dbus-1.0/include" ];
 
   preFixup = ''
     for f in $out/bin/* $out/libexec/*; do
diff --git a/pkgs/desktops/gnome-3/3.18/core/gdm/3.16-wip/default.nix b/pkgs/desktops/gnome-3/3.18/core/gdm/3.16-wip/default.nix
index 51b67afb01fd..b0e9652a9c51 100644
--- a/pkgs/desktops/gnome-3/3.18/core/gdm/3.16-wip/default.nix
+++ b/pkgs/desktops/gnome-3/3.18/core/gdm/3.16-wip/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   preConfigure = ''
     substituteInPlace ./configure --replace "/usr/bin/X" "${xorg.xorgserver}/bin/X"
     substituteInPlace daemon/gdm-simple-slave.c --replace 'BINDIR "/gnome-session' '"${gnome_session}/bin/gnome-session'
-    substituteInPlace daemon/gdm-launch-environment.c --replace 'BINDIR "/dbus-launch' '"${dbus.tools}/bin/dbus-launch'
+    substituteInPlace daemon/gdm-launch-environment.c --replace 'BINDIR "/dbus-launch' '"${dbus.dbus-launch}'
     substituteInPlace data/gdm.conf-custom.in --replace '#WaylandEnable=false' 'WaylandEnable=false'
     sed 's/#Enable=true/Enable=true/' -i data/gdm.conf-custom.in
  '';
diff --git a/pkgs/desktops/gnome-3/3.18/core/gnome-online-accounts/default.nix b/pkgs/desktops/gnome-3/3.18/core/gnome-online-accounts/default.nix
index b08aa1c99907..c6688fd30cd7 100644
--- a/pkgs/desktops/gnome-3/3.18/core/gnome-online-accounts/default.nix
+++ b/pkgs/desktops/gnome-3/3.18/core/gnome-online-accounts/default.nix
@@ -7,7 +7,7 @@
 stdenv.mkDerivation rec {
   inherit (import ./src.nix fetchurl) name src;
 
-  NIX_CFLAGS_COMPILE = "-I${dbus_glib.dev}/include/dbus-1.0 -I${dbus_libs}/include/dbus-1.0";
+  NIX_CFLAGS_COMPILE = "-I${dbus_glib.dev}/include/dbus-1.0 -I${dbus_libs.dev}/include/dbus-1.0";
 
   enableParallelBuilding = true;
 
diff --git a/pkgs/desktops/gnome-3/3.18/misc/gpaste/default.nix b/pkgs/desktops/gnome-3/3.18/misc/gpaste/default.nix
index dee9caf444c5..6c36f892bcc9 100644
--- a/pkgs/desktops/gnome-3/3.18/misc/gpaste/default.nix
+++ b/pkgs/desktops/gnome-3/3.18/misc/gpaste/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [ intltool autoreconfHook pkgconfig vala glib
-                  gtk3 gnome3.gnome_control_center dbus.libs
+                  gtk3 gnome3.gnome_control_center dbus
                   clutter pango appstream-glib makeWrapper ];
 
   preConfigure = "intltoolize -f";
diff --git a/pkgs/desktops/plasma-5.3/default.nix b/pkgs/desktops/plasma-5.3/default.nix
index 35c32829921b..dec9fca04a5b 100644
--- a/pkgs/desktops/plasma-5.3/default.nix
+++ b/pkgs/desktops/plasma-5.3/default.nix
@@ -236,7 +236,7 @@ let
       inherit (scope) bash coreutils gnused gnugrep socat;
       inherit (scope) kconfig kinit kservice qt5tools;
       inherit (scope.xorg) mkfontdir xmessage xprop xrdb xset xsetroot;
-      dbus_tools = scope.dbus.tools;
+      inherit (scope.dbus) dbus-launch;
       kde_workspace = kdeApps.kde-workspace;
       postPatch = ''
         substituteInPlace startkde/kstartupconfig/kstartupconfig.cpp \
diff --git a/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch b/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch
index bef2867f3434..5ab5d4585c06 100644
--- a/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch
+++ b/pkgs/desktops/plasma-5.3/plasma-workspace/0001-startkde-NixOS-patches.patch
@@ -180,7 +180,7 @@ index 6f93108..26cc2fc 100644
 +# Make sure that D-Bus is running
 +# D-Bus autolaunch is broken
 +if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
-+    eval `@dbus_tools@/bin/dbus-launch --sh-syntax --exit-with-session`
++    eval `@dbus-launch@ --sh-syntax --exit-with-session`
 +fi
 +if @qt5tools@/bin/qdbus >/dev/null 2>/dev/null; then
 +    : # ok
diff --git a/pkgs/desktops/plasma-5.4/plasma-workspace/0001-startkde-NixOS-patches.patch b/pkgs/desktops/plasma-5.4/plasma-workspace/0001-startkde-NixOS-patches.patch
index 6752258112ef..4c47e344e9fe 100644
--- a/pkgs/desktops/plasma-5.4/plasma-workspace/0001-startkde-NixOS-patches.patch
+++ b/pkgs/desktops/plasma-5.4/plasma-workspace/0001-startkde-NixOS-patches.patch
@@ -180,7 +180,7 @@ index cfbe227..999dd8f 100644
 +# Make sure that D-Bus is running
 +# D-Bus autolaunch is broken
 +if test -z "$DBUS_SESSION_BUS_ADDRESS" ; then
-+    eval `@dbus_tools@/bin/dbus-launch --sh-syntax --exit-with-session`
++    eval `@dbus-launch@ --sh-syntax --exit-with-session`
 +fi
 +if @qttools@/bin/qdbus >/dev/null 2>/dev/null; then
 +    : # ok
diff --git a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
index f9339f808062..d6537b82dd6e 100644
--- a/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
+++ b/pkgs/desktops/plasma-5.4/plasma-workspace/default.nix
@@ -44,7 +44,7 @@
 , kinit
 , kservice
 , qttools
-, dbus_tools
+, dbus
 , mkfontdir
 , xmessage
 , xprop
@@ -101,7 +101,8 @@ plasmaPackage {
 
   inherit bash coreutils gnused gnugrep socat;
   inherit kconfig kinit kservice qttools;
-  inherit dbus_tools mkfontdir xmessage xprop xrdb xset xsetroot;
+  inherit mkfontdir xmessage xprop xrdb xset xsetroot;
+  inherit (dbus) dbus-launch;
   postPatch = ''
     substituteAllInPlace startkde/startkde.cmake
     substituteInPlace startkde/kstartupconfig/kstartupconfig.cpp \