about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2015-07-22 21:20:44 +0200
committerLuca Bruno <lucabru@src.gnome.org>2015-07-22 21:20:44 +0200
commit7098832c6057cce376dc5d02532642d32a189d37 (patch)
treeba12c539f22bad557948321429fd1ec2fd837ea5 /pkgs/desktops
parente770d66a231472b3231859e664a6e0ca2a7a3e24 (diff)
downloadnixlib-7098832c6057cce376dc5d02532642d32a189d37.tar
nixlib-7098832c6057cce376dc5d02532642d32a189d37.tar.gz
nixlib-7098832c6057cce376dc5d02532642d32a189d37.tar.bz2
nixlib-7098832c6057cce376dc5d02532642d32a189d37.tar.lz
nixlib-7098832c6057cce376dc5d02532642d32a189d37.tar.xz
nixlib-7098832c6057cce376dc5d02532642d32a189d37.tar.zst
nixlib-7098832c6057cce376dc5d02532642d32a189d37.zip
lightsoff: init at 3.16.1.1
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.16/default.nix4
-rw-r--r--pkgs/desktops/gnome-3/3.16/games/lightsoff/default.nix31
2 files changed, 34 insertions, 1 deletions
diff --git a/pkgs/desktops/gnome-3/3.16/default.nix b/pkgs/desktops/gnome-3/3.16/default.nix
index bcabd9140a86..641a43b84178 100644
--- a/pkgs/desktops/gnome-3/3.16/default.nix
+++ b/pkgs/desktops/gnome-3/3.16/default.nix
@@ -32,7 +32,7 @@ let
     nautilus-sendto dconf-editor vinagre
   ];
 
-  gamesPackages = with gnome3; [ swell-foop ];
+  gamesPackages = with gnome3; [ swell-foop lightsoff ];
 
   inherit (pkgs) libsoup glib gtk2 webkitgtk24x gtk3 gtkmm3 libcanberra;
   inherit (pkgs.gnome2) ORBit2;
@@ -285,6 +285,8 @@ let
 
   swell-foop = callPackage ./games/swell-foop { };
 
+  lightsoff = callPackage ./games/lightsoff { };
+
 #### Misc -- other packages on http://ftp.gnome.org/pub/GNOME/sources/
 
   california = callPackage ./misc/california { };
diff --git a/pkgs/desktops/gnome-3/3.16/games/lightsoff/default.nix b/pkgs/desktops/gnome-3/3.16/games/lightsoff/default.nix
new file mode 100644
index 000000000000..e24f90812c0b
--- /dev/null
+++ b/pkgs/desktops/gnome-3/3.16/games/lightsoff/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchurl, pkgconfig, gtk3, gnome3, gdk_pixbuf, librsvg, makeWrapper
+, intltool, itstool, clutter, clutter_gtk, libxml2 }:
+
+stdenv.mkDerivation rec {
+  name = "lightsoff-${gnome3.version}.1.1";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/lightsoff/${gnome3.version}/${name}.tar.xz";
+    sha256 = "00a2jv7wr6fxrzk7avwa0wspz429ad7ri7v95jv31nqn5q73y4c0";
+  };
+
+  buildInputs = [ pkgconfig gtk3 gnome3.defaultIconTheme gdk_pixbuf librsvg
+                  libxml2 clutter clutter_gtk makeWrapper itstool intltool ];
+
+  enableParallelBuilding = true;
+
+  preFixup = ''
+    wrapProgram "$out/bin/lightsoff" \
+      --set GDK_PIXBUF_MODULE_FILE "$GDK_PIXBUF_MODULE_FILE" \
+      --prefix XDG_DATA_DIRS : "$XDG_ICON_DIRS:$GSETTINGS_SCHEMAS_PATH:$out/share" \
+      --prefix GIO_EXTRA_MODULES : "${gnome3.dconf}/lib/gio/modules"
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://wiki.gnome.org/Apps/Lightsoff;
+    description = "Puzzle game, where the objective is to turn off all of the tiles on the board";
+    maintainers = with maintainers; [ lethalman ];
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+  };
+}