about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-03-04 02:03:36 +0000
committerGitHub <noreply@github.com>2020-03-04 02:03:36 +0000
commit66c169a23589d2aba4620edd4ceb5f608125e626 (patch)
tree66cb186b62a143a39fd3d0141f82fc78f6ed8c10 /pkgs/desktops
parentb2f7754e837f15c5db660947580664dfaf545cc9 (diff)
parent50ad33cd0208510397c2a8a5423bf4b90b35c5bb (diff)
downloadnixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar.gz
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar.bz2
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar.lz
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar.xz
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.tar.zst
nixlib-66c169a23589d2aba4620edd4ceb5f608125e626.zip
Merge pull request #80323 from worldofpeace/gnome-tour
gnome-tour: init at 0.0.1
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/core/gnome-tour/default.nix81
1 files changed, 81 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/core/gnome-tour/default.nix b/pkgs/desktops/gnome-3/core/gnome-tour/default.nix
new file mode 100644
index 000000000000..108ff9afca70
--- /dev/null
+++ b/pkgs/desktops/gnome-3/core/gnome-tour/default.nix
@@ -0,0 +1,81 @@
+{ stdenv
+, rustPlatform
+, gettext
+, meson
+, ninja
+, fetchFromGitLab
+, pkg-config
+, gtk3
+, glib
+, gdk-pixbuf
+, desktop-file-utils
+, appstream-glib
+, wrapGAppsHook
+, python3
+, gnome3
+, config
+}:
+
+rustPlatform.buildRustPackage rec {
+  pname = "gnome-tour";
+  version = "0.0.1";
+
+  # We don't use the uploaded tar.xz because it comes pre-vendored
+  src = fetchFromGitLab {
+    domain = "gitlab.gnome.org";
+    owner = "GNOME";
+    repo = "gnome-tour";
+    rev = version;
+    sha256 = "0lbkspnlziq3z177071w3jpghmdwflzra1krdwchzmkfmrhy50ch";
+  };
+
+  cargoSha256 = "0k1wp9wswr57fv2d9bysxn97fchd4vz29n5r8gfyp0gcm8rclmij";
+
+  mesonFlags = [
+    "-Ddistro_name=NixOS"
+    "-Ddistro_icon_name=nix-snowflake"
+    "-Ddistro_version=20.09"
+  ];
+
+  nativeBuildInputs = [
+    appstream-glib
+    desktop-file-utils
+    gettext
+    meson
+    ninja
+    pkg-config
+    python3
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    gdk-pixbuf
+    glib
+    gtk3
+  ];
+
+  # Don't use buildRustPackage phases, only use it for rust deps setup
+  configurePhase = null;
+  buildPhase = null;
+  checkPhase = null;
+  installPhase = null;
+
+  postPatch = ''
+    chmod +x build-aux/meson_post_install.py
+    patchShebangs build-aux/meson_post_install.py
+  '';
+
+  # passthru = {
+  #   updateScript = gnome3.updateScript {
+  #     packageName = pname;
+  #   };
+  # };
+
+  meta = with stdenv.lib; {
+    homepage = "https://gitlab.gnome.org/GNOME/gnome-tour";
+    description = "GNOME Greeter & Tour";
+    maintainers = gnome3.maintainers;
+    license = licenses.gpl3Plus;
+    platforms = platforms.linux;
+  };
+}