about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorBobby Rong <rjl931189261@126.com>2023-06-08 19:33:53 +0800
committerBobby Rong <rjl931189261@126.com>2023-06-08 19:33:53 +0800
commit64aa3024b585f5eb77d52cafe6476eaba0329197 (patch)
tree15264c982e4d4d0530b72f1390883be40728fd72 /pkgs/desktops
parent1e8e84a59fdbdcb6a053066eb04d5596feb266ac (diff)
downloadnixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar.gz
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar.bz2
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar.lz
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar.xz
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.tar.zst
nixlib-64aa3024b585f5eb77d52cafe6476eaba0329197.zip
cinnamon.xapp: actually fix gtk3 module target dir
Before: $out/gtk-3.0/modules/libxapp-gtk3-module.so
After: $out/lib/gtk-3.0/modules/libxapp-gtk3-module.so

cat gtk+-3.0.pc | grep "libdir=" says `libdir=${prefix}/lib`, so install this there.

Another package that installs gtk3 module: libcanberra-gtk3
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/cinnamon/xapp/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/pkgs/desktops/cinnamon/xapp/default.nix b/pkgs/desktops/cinnamon/xapp/default.nix
index 719a8dd3968a..e09912478429 100644
--- a/pkgs/desktops/cinnamon/xapp/default.nix
+++ b/pkgs/desktops/cinnamon/xapp/default.nix
@@ -79,12 +79,11 @@ stdenv.mkDerivation rec {
     # Patch pastebin & inxi location
     sed "s|/usr/bin/pastebin|$out/bin/pastebin|" -i scripts/upload-system-info
     sed "s|'inxi'|'${inxi}/bin/inxi'|" -i scripts/upload-system-info
-
-    # Patch gtk3 module target dir
-    substituteInPlace libxapp/meson.build \
-         --replace "gtk3_dep.get_pkgconfig_variable('libdir')" "'$out'"
   '';
 
+  # Fix gtk3 module target dir. Proper upstream solution should be using define_variable.
+  PKG_CONFIG_GTK__3_0_LIBDIR = "${placeholder "out"}/lib";
+
   meta = with lib; {
     homepage = "https://github.com/linuxmint/xapp";
     description = "Cross-desktop libraries and common resources";