about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2020-05-13 16:48:47 +0200
committerJan Tojnar <jtojnar@gmail.com>2020-05-13 17:02:53 +0200
commit5df7471c149cb4f20bc1cf292dbb038b66404110 (patch)
tree751971886eb533f0a74f4e31d06a9a74424480cc /pkgs/desktops
parentc8683da483b4595976c40b2e4e79a5ea13ee4994 (diff)
downloadnixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar.gz
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar.bz2
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar.lz
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar.xz
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.tar.zst
nixlib-5df7471c149cb4f20bc1cf292dbb038b66404110.zip
chrome-gnome-shell: Fix missing introspection data
It was crashing with:

    TypeError: gobject `__main__+ChromeGNOMEShell' doesn't support property `application_id'

– that is the constructor of parent class Gio.Application does not recognize the kwarg.

This is typically caused by missing pygobject overrides but I think ones for Gio are built-in into pygobject.

Even weirder, adding just `${gobject-introspection}/lib/girepository-1.0` seems to fix the issue so it might be missing the whole typelib.
But then why does not it fail when importing it?

	from gi.repository import GLib, Gio

For now, I am adding the Gio typelib which should been done from the start but more debugging should be done since weirdness like this can bring more bugs.

Fixes: https://github.com/NixOS/nixpkgs/issues/87740
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/extensions/chrome-gnome-shell/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/extensions/chrome-gnome-shell/default.nix b/pkgs/desktops/gnome-3/extensions/chrome-gnome-shell/default.nix
index ee0bb82b284a..5308d4bee5ac 100644
--- a/pkgs/desktops/gnome-3/extensions/chrome-gnome-shell/default.nix
+++ b/pkgs/desktops/gnome-3/extensions/chrome-gnome-shell/default.nix
@@ -6,6 +6,7 @@
 , python3
 , gnome3
 , wrapGAppsHook
+, gobject-introspection
 }:
 
 let
@@ -25,6 +26,7 @@ stdenv.mkDerivation rec {
     ninja
     jq
     wrapGAppsHook
+    gobject-introspection # for setup-hook
   ];
 
   buildInputs = [
@@ -32,6 +34,7 @@ stdenv.mkDerivation rec {
     python
     pygobject3
     requests
+    gobject-introspection # for Gio typelib
   ];
 
   cmakeFlags = [