about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorRickard Nilsson <rickard.nilsson@telia.com>2012-05-21 14:58:16 +0000
committerRickard Nilsson <rickard.nilsson@telia.com>2012-05-21 14:58:16 +0000
commit5a270abcb65dd8a1ced0f764dfde7867de334d79 (patch)
treec7a5c819f846256d3fc6cea1f4e2d9adc0a959a4 /pkgs/desktops
parent6706ef1e9916178cf553c39ae8f78b55b5768c84 (diff)
downloadnixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar.gz
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar.bz2
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar.lz
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar.xz
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.tar.zst
nixlib-5a270abcb65dd8a1ced0f764dfde7867de334d79.zip
Added missing pygtk dependency to Gnome VTE library.
svn path=/nixpkgs/trunk/; revision=34194
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-2/desktop/vte/default.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/pkgs/desktops/gnome-2/desktop/vte/default.nix b/pkgs/desktops/gnome-2/desktop/vte/default.nix
index c061a2684792..c91522e695ef 100644
--- a/pkgs/desktops/gnome-2/desktop/vte/default.nix
+++ b/pkgs/desktops/gnome-2/desktop/vte/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, intltool, pkgconfig, glib, gtk, ncurses
-, pythonSupport ? false, python}:
+, pythonSupport ? false, python, pygtk}:
 
 stdenv.mkDerivation rec {
   name = "vte-0.28.0";
@@ -10,12 +10,19 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [ intltool pkgconfig glib gtk ncurses ] ++
-                stdenv.lib.optional pythonSupport python;
+                stdenv.lib.optionals pythonSupport [python pygtk];
                 
   configureFlags = ''
     ${if pythonSupport then "--enable-python" else "--disable-python"}
   '';
-  
+
+  postInstall = stdenv.lib.optionalString pythonSupport ''
+    cd $(toPythonPath $out)/gtk-2.0
+    for n in *; do
+      ln -s "gtk-2.0/$n" "../$n"
+    done
+  '';
+
   meta = {
     homepage = http://www.gnome.org/;
     description = "A library implementing a terminal emulator widget for GTK+";