about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2017-09-02 17:37:07 +0200
committerJan Tojnar <jtojnar@gmail.com>2017-09-02 17:43:16 +0200
commit4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7 (patch)
tree1e0ab1d649617d29101842589e547dda626ce4ef /pkgs/desktops
parent6ca6ea9e23035689efd3fb3d87df8a407a176d90 (diff)
downloadnixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar.gz
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar.bz2
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar.lz
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar.xz
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.tar.zst
nixlib-4069cb2b0f7e142a5e416e6e4313d6d79e65b7c7.zip
gnome3.gpaste: refactor
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/3.24/misc/gpaste/default.nix22
1 files changed, 5 insertions, 17 deletions
diff --git a/pkgs/desktops/gnome-3/3.24/misc/gpaste/default.nix b/pkgs/desktops/gnome-3/3.24/misc/gpaste/default.nix
index 2bfc6c73eb40..b7fd8d8e763b 100644
--- a/pkgs/desktops/gnome-3/3.24/misc/gpaste/default.nix
+++ b/pkgs/desktops/gnome-3/3.24/misc/gpaste/default.nix
@@ -1,5 +1,5 @@
-{ stdenv, fetchurl, autoreconfHook, pkgconfig, vala_0_32, glib, gjs, mutter
-, pango, gtk3, gnome3, dbus, clutter, appstream-glib, makeWrapper, systemd, gobjectIntrospection }:
+{ stdenv, fetchurl, autoreconfHook, pkgconfig, vala, glib, gjs, mutter
+, pango, gtk3, gnome3, dbus, clutter, appstream-glib, wrapGAppsHook, systemd, gobjectIntrospection }:
 
 stdenv.mkDerivation rec {
   version = "3.24.2";
@@ -10,9 +10,10 @@ stdenv.mkDerivation rec {
     sha256 = "16142jfpkz8qfs7zp9k3c5l9pnvxbr5yygj8jdpx6by1142s6340";
   };
 
-  buildInputs = [ autoreconfHook pkgconfig vala_0_32 glib gjs mutter
+  nativeBuildInputs = [ autoreconfHook pkgconfig vala wrapGAppsHook ];
+  buildInputs = [ glib gjs mutter
                   gtk3 gnome3.gnome_control_center dbus
-                  clutter pango appstream-glib makeWrapper systemd gobjectIntrospection ];
+                  clutter pango appstream-glib systemd gobjectIntrospection ];
 
   configureFlags = [ "--with-controlcenterdir=$(out)/gnome-control-center/keybindings"
                      "--with-dbusservicesdir=$(out)/share/dbus-1/services"
@@ -20,19 +21,6 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  preFixup =
-    let
-      libPath = stdenv.lib.makeLibraryPath
-        [ glib gtk3 clutter pango ];
-    in
-    ''
-      for i in $out/libexec/gpaste/*; do
-        wrapProgram $i \
-          --prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH" \
-          --prefix GI_TYPELIB_PATH : "$GI_TYPELIB_PATH"
-      done
-    '';
-
   meta = with stdenv.lib; {
     homepage = https://github.com/Keruspe/GPaste;
     description = "Clipboard management system with GNOME3 integration";