about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-12-22 22:59:21 -0500
committerGitHub <noreply@github.com>2019-12-22 22:59:21 -0500
commit35b7b1712509dcb3043deded4ddb82434bc4dd3e (patch)
tree3a919acb49c2d9bfd73f3eda947bc8e510fcc5b4 /pkgs/desktops
parent2ac1596c927398d3a8b27e66f3c0c4073681f19f (diff)
parent016c589bb4768cad423b9f33de83b203e236ba74 (diff)
downloadnixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar.gz
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar.bz2
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar.lz
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar.xz
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.tar.zst
nixlib-35b7b1712509dcb3043deded4ddb82434bc4dd3e.zip
Merge pull request #76116 from worldofpeace/pantheon-cleanup
Pantheon cleanups
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/pantheon/apps/switchboard/wrapper.nix6
-rw-r--r--pkgs/desktops/pantheon/default.nix31
-rw-r--r--pkgs/desktops/pantheon/desktop/wingpanel/wrapper.nix6
3 files changed, 10 insertions, 33 deletions
diff --git a/pkgs/desktops/pantheon/apps/switchboard/wrapper.nix b/pkgs/desktops/pantheon/apps/switchboard/wrapper.nix
index c0abb172806b..0abce8098535 100644
--- a/pkgs/desktops/pantheon/apps/switchboard/wrapper.nix
+++ b/pkgs/desktops/pantheon/apps/switchboard/wrapper.nix
@@ -5,10 +5,14 @@
 , switchboard
 , switchboardPlugs
 , plugs
+  # Only useful to disable for development testing.
+, useDefaultPlugs ? true
 }:
 
 let
-  selectedPlugs = if plugs == null then switchboardPlugs else plugs;
+  selectedPlugs =
+    if plugs == null then switchboardPlugs
+    else plugs ++ (lib.optional useDefaultPlugs switchboardPlugs);
 in
 symlinkJoin {
   name = "${switchboard.name}-with-plugs";
diff --git a/pkgs/desktops/pantheon/default.nix b/pkgs/desktops/pantheon/default.nix
index 6aa2a141876f..d4e6b192f200 100644
--- a/pkgs/desktops/pantheon/default.nix
+++ b/pkgs/desktops/pantheon/default.nix
@@ -3,37 +3,6 @@
 
 lib.makeScope pkgs.newScope (self: with self; {
 
-  apps = [
-    elementary-calculator elementary-calendar
-    elementary-camera elementary-code elementary-files
-    elementary-music elementary-photos elementary-screenshot-tool
-    elementary-terminal elementary-videos switchboard-with-plugs
-  ];
-
-  artwork = [
-    elementary-gtk-theme
-    elementary-icon-theme
-    elementary-sound-theme
-    elementary-wallpapers
-  ];
-
-  desktop = [
-    elementary-default-settings
-    elementary-session-settings
-    elementary-shortcut-overlay
-    gala
-    wingpanel-with-indicators
-  ];
-
-  services = [
-    cerbere
-    elementary-capnet-assist
-    elementary-settings-daemon
-    elementary-dpms-helper
-    pantheon-agent-geoclue2
-    pantheon-agent-polkit
-  ];
-
   switchboardPlugs = [
     switchboard-plug-a11y switchboard-plug-about
     switchboard-plug-applications switchboard-plug-bluetooth
diff --git a/pkgs/desktops/pantheon/desktop/wingpanel/wrapper.nix b/pkgs/desktops/pantheon/desktop/wingpanel/wrapper.nix
index 253c61b77909..a46a26cc9ea5 100644
--- a/pkgs/desktops/pantheon/desktop/wingpanel/wrapper.nix
+++ b/pkgs/desktops/pantheon/desktop/wingpanel/wrapper.nix
@@ -6,10 +6,14 @@
 , wingpanelIndicators
 , switchboard-with-plugs
 , indicators ? null
+  # Only useful to disable for development testing.
+, useDefaultIndicators ? true
 }:
 
 let
-  selectedIndicators = if indicators == null then wingpanelIndicators else indicators;
+  selectedIndicators =
+    if indicators == null then wingpanelIndicators
+    else indicators ++ (lib.optional useDefaultIndicators wingpanelIndicators);
 in
 symlinkJoin {
   name = "${wingpanel.name}-with-indicators";