about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2020-12-27 10:34:29 -0300
committerJosé Romildo Malaquias <malaquias@gmail.com>2020-12-27 14:30:07 -0300
commit34de28ed173658911a8c4bc04a51e3c35aa21080 (patch)
tree46d9d3ce4ef7640e71f646573a7e274d99c59af5 /pkgs/desktops
parentb5bf9da14d28952b2b88a4c51d556014e2d69397 (diff)
downloadnixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar.gz
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar.bz2
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar.lz
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar.xz
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.tar.zst
nixlib-34de28ed173658911a8c4bc04a51e3c35aa21080.zip
xfce: update src to use new git repository
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce/mkXfceDerivation.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/pkgs/desktops/xfce/mkXfceDerivation.nix b/pkgs/desktops/xfce/mkXfceDerivation.nix
index 4c6edf99b611..5200e43a4982 100644
--- a/pkgs/desktops/xfce/mkXfceDerivation.nix
+++ b/pkgs/desktops/xfce/mkXfceDerivation.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, pkgconfig, xfce4-dev-tools, hicolor-icon-theme, xfce, wrapGAppsHook }:
+{ stdenv, fetchFromGitLab, pkgconfig, xfce4-dev-tools, hicolor-icon-theme, xfce, wrapGAppsHook }:
 
 { category
 , pname
@@ -29,8 +29,10 @@ let
     buildInputs = [ hicolor-icon-theme ];
     configureFlags = [ "--enable-maintainer-mode" ];
 
-    src = fetchgit {
-      url = "git://git.xfce.org/${category}/${pname}";
+    src = fetchFromGitLab {
+      domain = "gitlab.xfce.org";
+      owner = category;
+      repo = pname;
       inherit rev sha256;
     };
 
@@ -41,11 +43,11 @@ let
 
     passthru.updateScript = xfce.updateScript {
       inherit pname version attrPath rev-prefix odd-unstable patchlevel-unstable;
-      versionLister = xfce.gitLister src.url;
+      versionLister = xfce.gitLister src.meta.homepage;
     };
 
     meta = with stdenv.lib; {
-      homepage = "https://git.xfce.org/${category}/${pname}/about";
+      homepage = "https://gitlab.xfce.org/${category}/${pname}/about";
       license = licenses.gpl2; # some libraries are under LGPLv2+
       platforms = platforms.linux;
     };