about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorTor Hedin Brønner <torhedinbronner@gmail.com>2018-03-14 19:37:33 +0100
committerJan Tojnar <jtojnar@gmail.com>2018-03-22 07:46:50 +0100
commit2c894fb1475e56f4cad50a0292f5e4c712762200 (patch)
tree1966804fd98bb1028199bd86554c23d110f23ec0 /pkgs/desktops
parent174a82141cdc9c41117e5f74c1783314326cc02f (diff)
downloadnixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar.gz
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar.bz2
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar.lz
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar.xz
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.tar.zst
nixlib-2c894fb1475e56f4cad50a0292f5e4c712762200.zip
gnome3.gnome-characters: fix build
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/apps/gnome-characters/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/desktops/gnome-3/apps/gnome-characters/default.nix b/pkgs/desktops/gnome-3/apps/gnome-characters/default.nix
index 8e1b0f33f758..7ca258483747 100644
--- a/pkgs/desktops/gnome-3/apps/gnome-characters/default.nix
+++ b/pkgs/desktops/gnome-3/apps/gnome-characters/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, meson, ninja, pkgconfig, gettext, gnome3, glib, gtk3, pango, wrapGAppsHook
-, gobjectIntrospection, gjs, gdk_pixbuf, librsvg }:
+, gobjectIntrospection, gjs, gdk_pixbuf, librsvg, libunistring }:
 
 stdenv.mkDerivation rec {
   name = "gnome-characters-${version}";
@@ -10,6 +10,11 @@ stdenv.mkDerivation rec {
     sha256 = "14q92ysg7krawxlwv6ymgsxz2plk81wgfz6knlma7lm13jsczmf0";
   };
 
+  postPatch = ''
+    chmod +x meson_post_install.py # patchShebangs requires executable file
+    patchShebangs meson_post_install.py
+  '';
+
   passthru = {
     updateScript = gnome3.updateScript {
       packageName = "gnome-characters";
@@ -18,7 +23,7 @@ stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ meson ninja pkgconfig gettext wrapGAppsHook gobjectIntrospection ];
-  buildInputs = [ glib gtk3 gjs pango gnome3.gsettings-desktop-schemas gnome3.defaultIconTheme ];
+  buildInputs = [ glib gtk3 gjs pango gnome3.gsettings-desktop-schemas gnome3.defaultIconTheme libunistring ];
 
   mesonFlags = [
     "-Ddbus_service_dir=${placeholder "out"}/share/dbus-1/services"