about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2017-09-19 04:03:57 +0200
committerJan Tojnar <jtojnar@gmail.com>2017-11-26 03:10:50 +0100
commit29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc (patch)
treec93826a2f1a3d65068d2cd5ce0705a515df54235 /pkgs/desktops
parent1c1d677149797d6be7e484b020aa4ac69efc55be (diff)
downloadnixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar.gz
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar.bz2
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar.lz
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar.xz
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.tar.zst
nixlib-29eff705ba7248a69d8bd5ea4da72ddfc19a4dbc.zip
gnome3.bijiben: mark as broken
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/apps/bijiben/default.nix32
-rw-r--r--pkgs/desktops/gnome-3/apps/bijiben/no-update-icon-cache.patch22
2 files changed, 41 insertions, 13 deletions
diff --git a/pkgs/desktops/gnome-3/apps/bijiben/default.nix b/pkgs/desktops/gnome-3/apps/bijiben/default.nix
index 9aae9215650f..ddff55c96a09 100644
--- a/pkgs/desktops/gnome-3/apps/bijiben/default.nix
+++ b/pkgs/desktops/gnome-3/apps/bijiben/default.nix
@@ -1,6 +1,6 @@
-{ stdenv, intltool, fetchurl, pkgconfig, glib
+{ stdenv, meson, ninja, gettext, fetchurl, pkgconfig, glib
 , evolution_data_server, evolution, sqlite
-, makeWrapper, itstool, desktop_file_utils
+, wrapGAppsHook, itstool, desktop_file_utils
 , clutter_gtk, libuuid, webkitgtk, zeitgeist
 , gnome3, librsvg, gdk_pixbuf, libxml2 }:
 
@@ -8,28 +8,34 @@ stdenv.mkDerivation rec {
   inherit (import ./src.nix fetchurl) name src;
 
   doCheck = true;
+  checkPhase = "meson test";
+
+  patches = [
+    ./no-update-icon-cache.patch
+  ];
+
+  postPatch = ''
+    chmod +x meson_post_install.py
+    patchShebangs meson_post_install.py
+  '';
 
   propagatedUserEnvPkgs = [ gnome3.gnome_themes_standard ];
 
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ glib intltool itstool libxml2
-                  clutter_gtk libuuid webkitgtk gnome3.tracker
-                  gnome3.gnome_online_accounts zeitgeist desktop_file_utils
-                  gnome3.gsettings_desktop_schemas makeWrapper
+  nativeBuildInputs = [
+    meson ninja pkgconfig gettext itstool libxml2 desktop_file_utils wrapGAppsHook
+  ];
+  buildInputs = [ glib clutter_gtk libuuid webkitgtk gnome3.tracker
+                  gnome3.gnome_online_accounts zeitgeist
+                  gnome3.gsettings_desktop_schemas
                   gdk_pixbuf gnome3.defaultIconTheme librsvg
                   evolution_data_server evolution sqlite ];
 
   enableParallelBuilding = true;
 
-  preFixup = ''
-    wrapProgram "$out/bin/bijiben" \
-      --set GDK_PIXBUF_MODULE_FILE "$GDK_PIXBUF_MODULE_FILE" \
-      --prefix XDG_DATA_DIRS : "${gnome3.gnome_themes_standard}/share:$XDG_ICON_DIRS:$GSETTINGS_SCHEMAS_PATH"
-  '';
-
   meta = with stdenv.lib; {
     homepage = https://wiki.gnome.org/Apps/Bijiben;
     description = "Note editor designed to remain simple to use";
+    broken = true;
     maintainers = gnome3.maintainers;
     license = licenses.gpl3;
     platforms = platforms.linux;
diff --git a/pkgs/desktops/gnome-3/apps/bijiben/no-update-icon-cache.patch b/pkgs/desktops/gnome-3/apps/bijiben/no-update-icon-cache.patch
new file mode 100644
index 000000000000..c8b0043fb45f
--- /dev/null
+++ b/pkgs/desktops/gnome-3/apps/bijiben/no-update-icon-cache.patch
@@ -0,0 +1,22 @@
+--- a/meson_post_install.py
++++ b/meson_post_install.py
+@@ -7,10 +7,6 @@
+ if not os.environ.get('DESTDIR'):
+   datadir = sys.argv[1]
+ 
+-  icondir = os.path.join(datadir, 'icons', 'hicolor')
+-  print('Update icon cache...')
+-  subprocess.call(['gtk-update-icon-cache', '-f', '-t', icondir])
+-
+   schemadir = os.path.join(datadir, 'glib-2.0', 'schemas')
+   print('Compile gsettings schemas...')
+   subprocess.call(['glib-compile-schemas', schemadir])
+@@ -18,8 +14,3 @@
+   desktop_file = os.path.join(datadir, 'applications', 'org.gnome.bijiben.desktop')
+   print('Validate desktop file...')
+   subprocess.call(['desktop-file-validate', desktop_file])
+-
+-  if sys.argv[2] == 'update-mimedb':
+-    mimedir = os.path.join(datadir, 'mime')
+-    print('Update mime database...')
+-    subprocess.call(['update-mime-database', mimedir])