about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-08-27 22:37:03 -0400
committerGitHub <noreply@github.com>2019-08-27 22:37:03 -0400
commit27a4afefbe9a8befd1eef1c0e1029216794445f0 (patch)
treeb7bafcabb6273d80d02bc055ffb564bcfa4be715 /pkgs/desktops
parentaf71811487509fbb6c04cb4484575cc6c0ca8701 (diff)
parentfd7d31b50e087e790443cd57eaf52f41c3f99af1 (diff)
downloadnixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar.gz
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar.bz2
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar.lz
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar.xz
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.tar.zst
nixlib-27a4afefbe9a8befd1eef1c0e1029216794445f0.zip
Merge pull request #66859 from worldofpeace/xfce4-14-module
 nixos/xfce4-14: init
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce4-14/default.nix8
-rw-r--r--pkgs/desktops/xfce4-14/xfce4-mixer/default.nix32
2 files changed, 6 insertions, 34 deletions
diff --git a/pkgs/desktops/xfce4-14/default.nix b/pkgs/desktops/xfce4-14/default.nix
index 82fe5b65356c..294dfa92c798 100644
--- a/pkgs/desktops/xfce4-14/default.nix
+++ b/pkgs/desktops/xfce4-14/default.nix
@@ -58,8 +58,6 @@ makeScope newScope (self: with self; {
 
   xfce4-dict = callPackage ./xfce4-dict { };
 
-  xfce4-mixer = callPackage ./xfce4-mixer { };
-
   xfce4-netload-plugin = callPackage ./xfce4-netload-plugin { };
 
   xfce4-notifyd = callPackage ./xfce4-notifyd { };
@@ -112,4 +110,10 @@ makeScope newScope (self: with self; {
   xfce4-namebar-plugin = callPackage ../xfce/panel-plugins/xfce4-namebar-plugin.nix { };
 
   xfce4-windowck-plugin = callPackage ../xfce/panel-plugins/xfce4-windowck-plugin.nix { };
+
+
+  ## ALIASES
+
+  # added 2019-08-18
+  xfce4-mixer = throw "deprecated 2019-08-18: obsoleted by xfce4-pulseaudio-plugin";
 })
diff --git a/pkgs/desktops/xfce4-14/xfce4-mixer/default.nix b/pkgs/desktops/xfce4-14/xfce4-mixer/default.nix
deleted file mode 100644
index a4bc0a3eaddb..000000000000
--- a/pkgs/desktops/xfce4-14/xfce4-mixer/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ mkXfceDerivation, automakeAddFlags, dbus-glib, gtk2, libxfce4ui, libxfce4util, xfce4-panel, xfconf, gst-plugins-base, libunique }:
-
-let
-  gst_plugins_minimal = gst-plugins-base.override {
-    minimalDeps = true;
-  };
-in
-mkXfceDerivation rec {
-  category = "apps";
-  pname = "xfce4-mixer";
-  version = "4.11.0";
-
-  sha256 = "1kiz5ysn4rqkjfzz4dvbsfj64kqqayg7bqakcys3rw28g2q5qyys";
-
-  nativeBuildInputs = [ automakeAddFlags ];
-
-  postPatch = ''
-    automakeAddFlags panel-plugin/Makefile.am libmixer_la_CFLAGS DBUS_GLIB_CFLAGS
-    automakeAddFlags xfce4-mixer/Makefile.am xfce4_mixer_CFLAGS DBUS_GLIB_CFLAGS
-  '';
-
-  buildInputs = [
-    dbus-glib
-    gst_plugins_minimal
-    gtk2
-    libunique
-    libxfce4ui
-    libxfce4util
-    xfce4-panel
-    xfconf
-  ];
-}