about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorromildo <malaquias@gmail.com>2017-08-30 23:55:20 -0300
committerromildo <malaquias@gmail.com>2017-08-30 23:55:20 -0300
commit20f3dfd5799be3f175a62c280897634b6d08b2ec (patch)
tree2029b7dc9c4879d7e85a6ec59e43603a88e5565e /pkgs/desktops
parent75d643ee838d455526380ac13a8ccb960e2e340d (diff)
downloadnixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar.gz
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar.bz2
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar.lz
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar.xz
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.tar.zst
nixlib-20f3dfd5799be3f175a62c280897634b6d08b2ec.zip
libmatemixer: init at 1.18.0
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/mate/default.nix2
-rw-r--r--pkgs/desktops/mate/libmatemixer/default.nix33
2 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/desktops/mate/default.nix b/pkgs/desktops/mate/default.nix
index 1764b32863ce..01c3d373d3c5 100644
--- a/pkgs/desktops/mate/default.nix
+++ b/pkgs/desktops/mate/default.nix
@@ -11,6 +11,7 @@ rec {
   engrampa = callPackage ./engrampa { };
   eom = callPackage ./eom { };
   libmatekbd = callPackage ./libmatekbd { };
+  libmatemixer = callPackage ./libmatemixer { };
   mate-common = callPackage ./mate-common { };
   mate-desktop = callPackage ./mate-desktop { };
   mate-icon-theme = callPackage ./mate-icon-theme { };
@@ -22,6 +23,7 @@ rec {
   basePackages = [
     caja
     libmatekbd
+    libmatemixer
     mate-common
     mate-desktop
     mate-icon-theme
diff --git a/pkgs/desktops/mate/libmatemixer/default.nix b/pkgs/desktops/mate/libmatemixer/default.nix
new file mode 100644
index 000000000000..614124f8a0c5
--- /dev/null
+++ b/pkgs/desktops/mate/libmatemixer/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, pkgconfig, intltool, glib
+, alsaSupport ? stdenv.isLinux, alsaLib
+, pulseaudioSupport ? stdenv.config.pulseaudio or true, libpulseaudio
+, ossSupport ? false
+ }:
+
+stdenv.mkDerivation rec {
+  name = "libmatemixer-${version}";
+  version = "${major-ver}.${minor-ver}";
+  major-ver = "1.18";
+  minor-ver = "0";
+
+  src = fetchurl {
+    url = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
+    sha256 = "09vyxnlnalws318gsafdfi5c6jwpp92pbafn1ddlqqds23ihk4mr";
+  };
+
+  nativeBuildInputs = [ pkgconfig intltool ];
+
+  buildInputs = [ glib ]
+    ++ stdenv.lib.optional alsaSupport alsaLib
+    ++ stdenv.lib.optional pulseaudioSupport libpulseaudio;
+
+  configureFlags = stdenv.lib.optional ossSupport "--enable-oss";
+
+  meta = with stdenv.lib; {
+    description = "Mixer library for MATE";
+    homepage = https://github.com/mate-desktop/libmatemixer;
+    license = with licenses; [ gpl2 lgpl2 ];
+    platforms = platforms.unix;
+    maintainers = [ maintainers.romildo ];
+  };
+}