about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-08-17 20:53:27 +0200
committerVladimír Čunát <vcunat@gmail.com>2018-08-17 20:53:27 +0200
commit14aa936ec52cc01c0b67470bf83b7b0b9aad6aef (patch)
treeb8b511e368df0c9583d41b9347673b3164a797dd /pkgs/desktops
parent6cb6ea1fed65bef4f2e9f02241a3e828c57fe57d (diff)
parent4ff7702082bad838e70140091afe7e77a9f00eca (diff)
downloadnixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar.gz
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar.bz2
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar.lz
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar.xz
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.tar.zst
nixlib-14aa936ec52cc01c0b67470bf83b7b0b9aad6aef.zip
Merge branch 'staging-next' into staging
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/default.nix4
-rw-r--r--pkgs/desktops/gnome-3/games/atomix/default.nix37
-rw-r--r--pkgs/desktops/gnome-3/misc/libgnome-games-support/default.nix6
3 files changed, 45 insertions, 2 deletions
diff --git a/pkgs/desktops/gnome-3/default.nix b/pkgs/desktops/gnome-3/default.nix
index 478dfc5d9f41..18db0e5ba812 100644
--- a/pkgs/desktops/gnome-3/default.nix
+++ b/pkgs/desktops/gnome-3/default.nix
@@ -34,7 +34,7 @@ lib.makeScope pkgs.newScope (self: with self; {
   ];
 
   gamesPackages = with gnome3; [ swell-foop lightsoff iagno
-    tali quadrapassel gnome-sudoku aisleriot five-or-more
+    tali quadrapassel gnome-sudoku atomix aisleriot five-or-more
     four-in-a-row gnome-chess gnome-klotski gnome-mahjongg
     gnome-mines gnome-nibbles gnome-robots gnome-tetravex
     hitori gnome-taquin
@@ -319,6 +319,8 @@ lib.makeScope pkgs.newScope (self: with self; {
 
   aisleriot = callPackage ./games/aisleriot { };
 
+  atomix = callPackage ./games/atomix { };
+
   five-or-more = callPackage ./games/five-or-more { };
 
   four-in-a-row = callPackage ./games/four-in-a-row { };
diff --git a/pkgs/desktops/gnome-3/games/atomix/default.nix b/pkgs/desktops/gnome-3/games/atomix/default.nix
new file mode 100644
index 000000000000..8ea4b82ca039
--- /dev/null
+++ b/pkgs/desktops/gnome-3/games/atomix/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, meson, ninja, pkgconfig, wrapGAppsHook
+, gettext, gnome3, glib, gtk3, libgnome-games-support, gdk_pixbuf }:
+
+let
+  pname = "atomix";
+  version = "3.29.3";
+in stdenv.mkDerivation rec {
+  name = "${pname}-${version}";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${name}.tar.xz";
+    sha256 = "1k8bvwywpvw5f13pw40brk6c3rz2mdz9cd4zhcawg7qdm77dvcvb";
+  };
+
+  nativeBuildInputs = [ meson ninja pkgconfig gettext wrapGAppsHook ];
+  buildInputs = [ glib gtk3 gdk_pixbuf libgnome-games-support gnome3.defaultIconTheme ];
+
+  postPatch = ''
+    chmod +x meson_post_install.py
+    patchShebangs meson_post_install.py
+  '';
+
+  passthru = {
+    updateScript = gnome3.updateScript {
+      packageName = pname;
+      attrPath = "gnome3.${pname}";
+    };
+  };
+
+  meta = with stdenv.lib; {
+    description = "Puzzle game where you move atoms to build a molecule";
+    homepage = https://wiki.gnome.org/Apps/Atomix;
+    license = licenses.gpl2Plus;
+    maintainers = gnome3.maintainers;
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/desktops/gnome-3/misc/libgnome-games-support/default.nix b/pkgs/desktops/gnome-3/misc/libgnome-games-support/default.nix
index 3b580abed12c..7e28c90813a0 100644
--- a/pkgs/desktops/gnome-3/misc/libgnome-games-support/default.nix
+++ b/pkgs/desktops/gnome-3/misc/libgnome-games-support/default.nix
@@ -13,7 +13,11 @@ in stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ pkgconfig intltool ];
-  buildInputs = [ glib gtk3 libgee libintl ];
+  buildInputs = [ libintl ];
+  propagatedBuildInputs = [
+    # Required by libgnome-games-support-1.pc
+    glib gtk3 libgee
+  ];
 
   passthru = {
     updateScript = gnome3.updateScript {