about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-03-28 19:38:33 -0400
committerworldofpeace <worldofpeace@protonmail.ch>2020-04-05 20:39:11 -0400
commit120a2f30338669b0099d70eb40a8f13c9276c135 (patch)
treec7ce705dd615a871cd1182589ec6153ae0d5b3ae /pkgs/desktops
parent83eafe80f295ab8d30933cc546a410e6117f31f4 (diff)
downloadnixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar.gz
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar.bz2
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar.lz
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar.xz
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.tar.zst
nixlib-120a2f30338669b0099d70eb40a8f13c9276c135.zip
pantheon.cerbere: remove
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/pantheon/default.nix4
-rw-r--r--pkgs/desktops/pantheon/services/cerbere/default.nix58
2 files changed, 2 insertions, 60 deletions
diff --git a/pkgs/desktops/pantheon/default.nix b/pkgs/desktops/pantheon/default.nix
index d4e6b192f200..8f9110c154b0 100644
--- a/pkgs/desktops/pantheon/default.nix
+++ b/pkgs/desktops/pantheon/default.nix
@@ -99,8 +99,6 @@ lib.makeScope pkgs.newScope (self: with self; {
 
   #### SERVICES
 
-  cerbere = callPackage ./services/cerbere { };
-
   contractor = callPackage ./services/contractor { };
 
   elementary-capnet-assist = callPackage ./services/elementary-capnet-assist { };
@@ -200,4 +198,6 @@ lib.makeScope pkgs.newScope (self: with self; {
 
   inherit (pkgs) vala; # added 2019-10-10
 
+  cerbere = throw "Cerbere is now obsolete https://github.com/elementary/cerbere/releases/tag/2.5.1.";
+
 })
diff --git a/pkgs/desktops/pantheon/services/cerbere/default.nix b/pkgs/desktops/pantheon/services/cerbere/default.nix
deleted file mode 100644
index 02c885198b62..000000000000
--- a/pkgs/desktops/pantheon/services/cerbere/default.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ stdenv
-, fetchFromGitHub
-, pantheon
-, pkgconfig
-, meson
-, python3
-, ninja
-, glib
-, libgee
-, vala_0_46
-, wrapGAppsHook
-}:
-
-stdenv.mkDerivation rec {
-  pname = "cerbere";
-  version = "2.5.0";
-
-  src = fetchFromGitHub {
-    owner = "elementary";
-    repo = pname;
-    rev = version;
-    sha256 = "12y6gg4vyc1rhdm2c7pr7bgmdrah7ddphyh25fgh3way8l9gh7vw";
-  };
-
-  passthru = {
-    updateScript = pantheon.updateScript {
-      attrPath = "pantheon.${pname}";
-    };
-  };
-
-  nativeBuildInputs = [
-    meson
-    ninja
-    pkgconfig
-    python3
-    vala_0_46
-    wrapGAppsHook
-  ];
-
-  buildInputs = [
-    glib
-    libgee
-  ];
-
-  postPatch = ''
-    chmod +x meson/post_install.py
-    patchShebangs meson/post_install.py
-  '';
-
-  meta = with stdenv.lib; {
-    description = "A simple service to ensure uptime of essential processes";
-    homepage = https://github.com/elementary/cerbere;
-    license = licenses.gpl2Plus;
-    platforms = platforms.linux;
-    maintainers = pantheon.maintainers;
-  };
-
-}