about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorOPNA2608 <christoph.neidahl@gmail.com>2023-12-23 09:46:19 +0100
committerOPNA2608 <christoph.neidahl@gmail.com>2023-12-23 09:46:19 +0100
commit0c90ac55d14af608b00091f35fa22e62af6fb4fe (patch)
tree82c457dc2d0a994b84e63442b0edcff5dae33b00 /pkgs/desktops
parent66bda599f409f9834c6fd6abc602e452a5c16b61 (diff)
downloadnixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar.gz
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar.bz2
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar.lz
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar.xz
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.tar.zst
nixlib-0c90ac55d14af608b00091f35fa22e62af6fb4fe.zip
lomiri.hfd-service: Fix accountsservice interface linking
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/lomiri/services/hfd-service/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/desktops/lomiri/services/hfd-service/default.nix b/pkgs/desktops/lomiri/services/hfd-service/default.nix
index cffedb0af623..e9ae4a0fe2db 100644
--- a/pkgs/desktops/lomiri/services/hfd-service/default.nix
+++ b/pkgs/desktops/lomiri/services/hfd-service/default.nix
@@ -31,10 +31,11 @@ stdenv.mkDerivation (finalAttrs: {
 
     # Queries pkg-config via pkg_get_variable, can't override prefix
     substituteInPlace init/CMakeLists.txt \
-      --replace "\''${SYSTEMD_SYSTEM_DIR}" "$out/lib/systemd/system"
+      --replace 'pkg_get_variable(SYSTEMD_SYSTEM_DIR systemd systemdsystemunitdir)' 'set(SYSTEMD_SYSTEM_DIR ''${CMAKE_INSTALL_PREFIX}/lib/systemd/system)'
     substituteInPlace CMakeLists.txt \
-      --replace 'pkg_get_variable(AS_INTERFACES_DIR accountsservice interfacesdir)' 'set(AS_INTERFACES_DIR "''${CMAKE_INSTALL_DATADIR}/accountsservice/interfaces")' \
-      --replace 'DESTINATION ''${DBUS_INTERFACES_DIR}' 'DESTINATION ${placeholder "out"}/''${DBUS_INTERFACES_DIR}'
+      --replace 'pkg_get_variable(AS_INTERFACES_DIR accountsservice interfacesdir)' 'set(AS_INTERFACES_DIR "''${CMAKE_INSTALL_FULL_DATADIR}/accountsservice/interfaces")' \
+      --replace '../../dbus-1/interfaces' "\''${CMAKE_INSTALL_PREFIX}/\''${DBUS_INTERFACES_DIR}" \
+      --replace 'DESTINATION ''${DBUS_INTERFACES_DIR}' 'DESTINATION ''${CMAKE_INSTALL_PREFIX}/''${DBUS_INTERFACES_DIR}'
     substituteInPlace src/CMakeLists.txt \
       --replace "\''${DBUS_INTERFACES_DIR}/org.freedesktop.Accounts.xml" '${accountsservice}/share/dbus-1/interfaces/org.freedesktop.Accounts.xml'
   '';