about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2014-11-04 00:54:08 +0300
committerMichael Raskin <7c6f434c@mail.ru>2014-11-04 00:54:15 +0300
commitf891bc78d15d22442ab1311b7a740562020352fe (patch)
treeb1d810aa3ee443ba17d465b4012bc4c8fb6a45c6 /pkgs/data
parentb7f7341169056082b9841dd5957ea729103aa394 (diff)
downloadnixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar.gz
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar.bz2
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar.lz
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar.xz
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.tar.zst
nixlib-f891bc78d15d22442ab1311b7a740562020352fe.zip
Add a binary-distribution-based Liberation fonts package
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/redhat-liberation-fonts/binary.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/pkgs/data/fonts/redhat-liberation-fonts/binary.nix b/pkgs/data/fonts/redhat-liberation-fonts/binary.nix
new file mode 100644
index 000000000000..cc6f9c6b5cc4
--- /dev/null
+++ b/pkgs/data/fonts/redhat-liberation-fonts/binary.nix
@@ -0,0 +1,49 @@
+{stdenv, fetchurl}:
+
+stdenv.mkDerivation rec {
+  version = "2.00.1";
+  name = "liberation-fonts-${version}";
+  src = fetchurl {
+    url = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-${version}.tar.gz";
+    sha256 = "010m4zfqan4w04b6bs9pm3gapn9hsb18bmwwgp2p6y6idj52g43q";
+  };
+  
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp -v $( find . -name '*.ttf') $out/share/fonts/truetype
+
+    mkdir -p "$out/doc/${name}"
+    cp -v AUTHORS ChangeLog COPYING License.txt README "$out/doc/${name}" || true
+  '';
+
+  meta = {
+    description = "Liberation Fonts, replacements for Times New Roman, Arial, and Courier New";
+
+    longDescription = ''
+      The Liberation Fonts are intended to be replacements for the three most
+      commonly used fonts on Microsoft systems: Times New Roman, Arial, and
+      Courier New.
+
+      There are three sets: Sans (a substitute for Arial, Albany, Helvetica,
+      Nimbus Sans L, and Bitstream Vera Sans), Serif (a substitute for Times
+      New Roman, Thorndale, Nimbus Roman, and Bitstream Vera Serif) and Mono
+      (a substitute for Courier New, Cumberland, Courier, Nimbus Mono L, and
+      Bitstream Vera Sans Mono).
+
+      You are free to use these fonts on any system you would like.  You are
+      free to redistribute them under the GPL+exception license found in the
+      download.  Using these fonts does not subject your documents to the
+      GPL---it liberates them from any proprietary claim.
+    '';
+
+    # See `License.txt' for details.
+    license = "GPLv2 + exception";
+
+    homepage = https://fedorahosted.org/liberation-fonts/;
+
+    maintainers = [
+      stdenv.lib.maintainers.raskin
+      stdenv.lib.maintainers.ludo
+    ];
+  };
+}