about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2019-01-20 11:04:03 +0000
committerGitHub <noreply@github.com>2019-01-20 11:04:03 +0000
commite611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d (patch)
treef12b92813b7b38a6550d3605b641b92f105ec7c9 /pkgs/data
parent5e6ae9b6a51a1ab4a182b23f5bc883e4ae7f6692 (diff)
parentc58807f764e44c470b5ca11707f299593c364350 (diff)
downloadnixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar.gz
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar.bz2
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar.lz
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar.xz
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.tar.zst
nixlib-e611684e2ce87f72c1c0f9df7d0f2682c8b4fe3d.zip
Merge pull request #54336 from romildo/upd.nordic
nordic: 1.3.0 -> 1.5.4
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/themes/nordic/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/pkgs/data/themes/nordic/default.nix b/pkgs/data/themes/nordic/default.nix
new file mode 100644
index 000000000000..93df3c723dd5
--- /dev/null
+++ b/pkgs/data/themes/nordic/default.nix
@@ -0,0 +1,43 @@
+{ stdenv, fetchurl, gtk-engine-murrine }:
+
+stdenv.mkDerivation rec {
+  name = "nordic-${version}";
+  version = "1.5.4";
+
+  srcs = [
+    (fetchurl {
+      url = "https://github.com/EliverLara/Nordic/releases/download/v${version}/Nordic.tar.xz";
+      sha256 = "0m00hwr6ms9fzlpl97d972wvgq5l0m11mpn213248a8sqbh2zz9g";
+    })
+    (fetchurl {
+      url = "https://github.com/EliverLara/Nordic/releases/download/v${version}/Nordic-blue.tar.xz";
+      sha256 = "05k1m9f0q4mfaqp2as3ymjsqmyz0bs5cd576srd5v952dzxmmbm2";
+    })
+    (fetchurl {
+      url = "https://github.com/EliverLara/Nordic/releases/download/v${version}/Nordic-standard-buttons.tar.xz";
+      sha256 = "1qps13fpp8y83c25c51w7kyds266gmks8c7kjp23iybij2lkny1m";
+    })
+    (fetchurl {
+      url = "https://github.com/EliverLara/Nordic/releases/download/v${version}/Nordic-blue-standard-buttons.tar.xz";
+      sha256 = "1c0j6qsxa6zahrl9ad0q6pczgbmm8qn9qsd7k41yk2ndh9iqzr5y";
+    })
+  ];
+
+  sourceRoot = ".";
+
+  propagatedUserEnvPkgs = [ gtk-engine-murrine ];
+
+  installPhase = ''
+    mkdir -p $out/share/themes
+    cp -a Nordic* $out/share/themes
+    rm $out/share/themes/*/{LICENSE,README.md}
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Dark Gtk theme created using the awesome Nord color pallete";
+    homepage = https://github.com/EliverLara/Nordic;
+    license = licenses.gpl3;
+    platforms = platforms.all;
+    maintainers = [ maintainers.romildo ];
+  };
+}