about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-11-26 00:14:00 +0000
committerGitHub <noreply@github.com>2023-11-26 00:14:00 +0000
commitdba51c8df8c8e01a7ce9a02f02c4cd11af25d49f (patch)
tree6aa21c70f0be43641110750eefbe8ee8aef689e5 /pkgs/data
parent28db109a585f3ddecf6fa3878d36da889651f12b (diff)
parent9cc575741df943328b2dbbf6ef7c5dfd49c1bbe0 (diff)
downloadnixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar.gz
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar.bz2
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar.lz
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar.xz
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.tar.zst
nixlib-dba51c8df8c8e01a7ce9a02f02c4cd11af25d49f.zip
Merge master into haskell-updates
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/open-dyslexic/default.nix18
-rw-r--r--pkgs/data/themes/marwaita-pop_os/default.nix9
-rw-r--r--pkgs/data/themes/marwaita-ubuntu/default.nix12
3 files changed, 24 insertions, 15 deletions
diff --git a/pkgs/data/fonts/open-dyslexic/default.nix b/pkgs/data/fonts/open-dyslexic/default.nix
index 8a6b01b1d6d7..bcfc9fda2b2d 100644
--- a/pkgs/data/fonts/open-dyslexic/default.nix
+++ b/pkgs/data/fonts/open-dyslexic/default.nix
@@ -1,19 +1,21 @@
-{ lib, stdenvNoCC, fetchzip }:
+{ lib, stdenvNoCC, fetchFromGitHub }:
 
+let version = "0.91.12"; in
 stdenvNoCC.mkDerivation {
   pname = "open-dyslexic";
-  version = "2016-06-23";
+  inherit version;
 
-  src = fetchzip {
-    url = "https://github.com/antijingoist/open-dyslexic/archive/20160623-Stable.zip";
-    hash = "sha256-f/uavR3n0qHyqumZDw7r8Zy0om2RlJAKyWuGaUXSJ1s=";
+  src = fetchFromGitHub {
+    owner = "antijingoist";
+    repo = "opendyslexic";
+    rev = "v${version}";
+    hash = "sha256-a8hh8NGt5djj9EC7ChO3SnnjuYMOryzbHWTK4gC/vIw=";
   };
 
   installPhase = ''
     runHook preInstall
 
-    install -Dm644 otf/*.otf -t $out/share/fonts/opentype
-    install -Dm644 README.md -t $out/share/doc/open-dyslexic
+    install -Dm644 compiled/*.otf -t $out/share/fonts/opentype
 
     runHook postInstall
   '';
@@ -21,7 +23,7 @@ stdenvNoCC.mkDerivation {
   meta = with lib; {
     homepage = "https://opendyslexic.org/";
     description = "Font created to increase readability for readers with dyslexia";
-    license = "Bitstream Vera License (https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts)";
+    license = licenses.ofl;
     platforms = platforms.all;
     maintainers = [ maintainers.rycee ];
   };
diff --git a/pkgs/data/themes/marwaita-pop_os/default.nix b/pkgs/data/themes/marwaita-pop_os/default.nix
index ca35460eff14..33e75cdd08c2 100644
--- a/pkgs/data/themes/marwaita-pop_os/default.nix
+++ b/pkgs/data/themes/marwaita-pop_os/default.nix
@@ -5,17 +5,18 @@
 , gtk-engine-murrine
 , gtk_engines
 , librsvg
+, gitUpdater
 }:
 
 stdenv.mkDerivation rec {
   pname = "marwaita-pop_os";
-  version = "10.3";
+  version = "17.0";
 
   src = fetchFromGitHub {
     owner = "darkomarko42";
     repo = pname;
-    rev = version;
-    sha256 = "1j6d91kx6iw8sy35rhhjvwb3qz60bvf7a7g7q2i0sznzdicrwsq6";
+    rev = "1f3561f1231d0e9e931f93c5d59df19ed2205ce0";
+    hash = "sha256-WbCIMEWF5853TQyhq8aRoWzpsmjObm9hEc4I0pxDNOM=";
   };
 
   buildInputs = [
@@ -37,6 +38,8 @@ stdenv.mkDerivation rec {
     runHook postInstall
   '';
 
+  passthru.updateScript = gitUpdater { };
+
   meta = with lib; {
     description = "Marwaita GTK theme with Pop_os Linux style";
     homepage = "https://www.pling.com/p/1377894/";
diff --git a/pkgs/data/themes/marwaita-ubuntu/default.nix b/pkgs/data/themes/marwaita-ubuntu/default.nix
index f98e112678ce..4190b1c0c3d2 100644
--- a/pkgs/data/themes/marwaita-ubuntu/default.nix
+++ b/pkgs/data/themes/marwaita-ubuntu/default.nix
@@ -1,20 +1,22 @@
-{ lib, stdenv
+{ lib
+, stdenv
 , fetchFromGitHub
 , gdk-pixbuf
 , gtk-engine-murrine
 , gtk_engines
 , librsvg
+, gitUpdater
 }:
 
 stdenv.mkDerivation rec {
   pname = "marwaita-ubuntu";
-  version = "1.7";
+  version = "17.0";
 
   src = fetchFromGitHub {
     owner = "darkomarko42";
     repo = pname;
-    rev = version;
-    sha256 = "024b0817jilvi5ilq9sbwg19ql5i2x3jfgc1awk7zzv6sqii639x";
+    rev = "481aae16034e0321bcabd14270639b8bd8b9aa73";
+    hash = "sha256-Ze2nR+77qe0TfwcvXP9eheB7mXSSVdejk11GS0fx7LY=";
   };
 
   buildInputs = [
@@ -36,6 +38,8 @@ stdenv.mkDerivation rec {
     runHook postInstall
   '';
 
+  passthru.updateScript = gitUpdater { };
+
   meta = with lib; {
     description = "Ubuntu Style of Marwaita GTK theme";
     homepage = "https://www.pling.com/p/1352833/";