about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorAndreas Baldeau <andreas@baldeau.net>2015-04-26 11:44:43 +0200
committerAndreas Baldeau <andreas@baldeau.net>2015-05-03 14:55:04 +0200
commitc7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2 (patch)
treecc514af7665971118c399cd0ab015049f3c38f8d /pkgs/data
parent365fd9efeb8e5d0918e641fc24922bd9e48041a6 (diff)
downloadnixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar.gz
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar.bz2
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar.lz
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar.xz
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.tar.zst
nixlib-c7bb01cfa24ecc1c8d8f63f2c0d4f886bf0a32d2.zip
Added Font Awesome TTF font.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/font-awesome-ttf/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/data/fonts/font-awesome-ttf/default.nix b/pkgs/data/fonts/font-awesome-ttf/default.nix
new file mode 100644
index 000000000000..7e07ec8a37c3
--- /dev/null
+++ b/pkgs/data/fonts/font-awesome-ttf/default.nix
@@ -0,0 +1,31 @@
+{stdenv, fetchurl, unzip}:
+
+stdenv.mkDerivation rec {
+  name = "font-awesome-4.3.0";
+
+  src = fetchurl {
+    url = "http://fortawesome.github.io/Font-Awesome/assets/${name}.zip";
+    sha256 = "018syfvkj01jym60mpys93xv84ky9l2x90gprnm9npzwkw5169jc";
+  };
+
+  buildCommand = ''
+    ${unzip}/bin/unzip $src
+    mkdir -p $out/share/fonts/truetype
+    cp */fonts/*.ttf $out/share/fonts/truetype
+  '';
+
+  meta = {
+    description = "Font Awesome - TTF font";
+
+    longDescription = ''
+      Font Awesome gives you scalable vector icons that can instantly be customized.
+      This package includes only the TTF font. For full CSS etc. see the project website.
+    '';
+
+    homepage = "http://fortawesome.github.io/Font-Awesome/";
+    license = stdenv.lib.licenses.ofl;
+
+    platforms = stdenv.lib.platforms.all;
+    maintainers = [ stdenv.lib.maintainers.abaldeau ];
+  };
+}