about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@users.noreply.github.com>2016-07-02 13:59:31 +0200
committerGitHub <noreply@github.com>2016-07-02 13:59:31 +0200
commitc4ba6cbcf21a2084b904d0dfe8e93aefe562307b (patch)
tree2a4f24be5c129b18f643251414819fcdf6d92e94 /pkgs/data
parented01d6f7d395d918d8fef473355c39d0dd5de34d (diff)
parent969433f229371c522c51d9216fdfefd95a1a59c6 (diff)
downloadnixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar.gz
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar.bz2
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar.lz
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar.xz
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.tar.zst
nixlib-c4ba6cbcf21a2084b904d0dfe8e93aefe562307b.zip
Merge pull request #16618 from leenaars/norwester
norwester-font: init at 1.2
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/norwester/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/data/fonts/norwester/default.nix b/pkgs/data/fonts/norwester/default.nix
new file mode 100644
index 000000000000..cc2a2617f344
--- /dev/null
+++ b/pkgs/data/fonts/norwester/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation rec {
+  pname = "norwester";
+  version = "1.2";
+  name = "${pname}-${version}";
+
+  src = fetchurl {
+    url = "http://jamiewilson.io/norwester/assets/norwester.zip";
+    sha256 = "0syg8ss7mpli4cbxvh3ld7qrlbhb2dfv3wchm765iw6ndc05g92d";
+  };
+
+  phases = [ "installPhase" ];
+
+  buildInputs = [ unzip ];
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype
+    unzip -D -j $src ${pname}-v${version}/${pname}.otf -d $out/share/fonts/opentype/
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://jamiewilson.io/norwester";
+    description = "A condensed geometric sans serif by Jamie Wilson";
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+    platforms = platforms.all;
+  };
+}