about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-05-01 11:46:16 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2019-05-01 11:46:16 +0200
commitbd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee (patch)
treece14ea68baea6afac0e80530e365ac22910dc0b7 /pkgs/data
parentd5b3b356de63e676b623aa2a49884a580d0ba507 (diff)
parentf13778392713bca1aca3b9252c727cf0556d6b2b (diff)
downloadnixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar.gz
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar.bz2
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar.lz
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar.xz
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.tar.zst
nixlib-bd9e44fce3cb3bb0200f238ea7e89ff3b183b1ee.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/d2coding/default.nix32
-rw-r--r--pkgs/data/fonts/nanum-gothic-coding/default.nix25
2 files changed, 57 insertions, 0 deletions
diff --git a/pkgs/data/fonts/d2coding/default.nix b/pkgs/data/fonts/d2coding/default.nix
new file mode 100644
index 000000000000..abc0dba81654
--- /dev/null
+++ b/pkgs/data/fonts/d2coding/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchzip, unzip }:
+
+let
+  version = "1.3.2";
+  pname = "d2codingfont";
+
+in fetchzip rec {
+  name = "${pname}-${version}";
+  url = "https://github.com/naver/${pname}/releases/download/VER${version}/D2Coding-Ver${version}-20180524.zip";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts
+    unzip -j $downloadedFile \*-all.ttc -d $out/share/fonts/truetype/
+  '';
+
+  sha256 = "1812r82530wzfki7k9cm35fy6k2lvis7j6w0w8svc784949m1wwj";
+
+  meta = with stdenv.lib; {
+    description = "Monospace font with support for Korean and latin characters";
+    longDescription = ''
+      D2Coding is a monospace font developed by a Korean IT Company called Naver.
+      Font is good for displaying both Korean characters and latin characters,
+      as sometimes these two languages could share some similar strokes.
+      Since verion 1.3, D2Coding font is officially supported by the font
+      creator, with symbols for Powerline.
+    '';
+    homepage = https://github.com/naver/d2codingfont;
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ dtzWill ];
+  };
+}
diff --git a/pkgs/data/fonts/nanum-gothic-coding/default.nix b/pkgs/data/fonts/nanum-gothic-coding/default.nix
new file mode 100644
index 000000000000..c0b4670a659b
--- /dev/null
+++ b/pkgs/data/fonts/nanum-gothic-coding/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchzip, unzip}:
+
+let
+  version = "VER2.5";
+  fullName = "NanumGothicCoding-2.5";
+
+in fetchzip rec {
+  name = "nanum-gothic-coding";
+  url = "https://github.com/naver/nanumfont/releases/download/${version}/${fullName}.zip";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/NanumGothicCoding
+    unzip -j $downloadedFile \*.ttf -d $out/share/fonts/NanumGothicCoding
+  '';
+
+  sha256 = "0b3pkhd6xn6393zi0dhj3ah08w1y1ji9fl6584bi0c8lanamf2pc";
+
+  meta = with stdenv.lib; {
+    description = "A contemporary monospaced sans-serif typeface with a warm touch";
+    homepage = https://github.com/naver/nanumfont;
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ linarcx ];
+  };
+}