about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJonathan Glines <auntieNeo@gmail.com>2014-06-11 22:05:16 -0600
committerJonathan Glines <auntieNeo@gmail.com>2014-06-11 22:08:14 -0600
commitb913409e0bcf93706f2e2f6b25809ab30bd124ec (patch)
treebea959366d354bc75d81c05943db8ac58c49dd01 /pkgs/data
parent0672cfcc5f8bf556905555e111e184bb6df28e7b (diff)
downloadnixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar.gz
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar.bz2
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar.lz
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar.xz
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.tar.zst
nixlib-b913409e0bcf93706f2e2f6b25809ab30bd124ec.zip
Removed non-free kochi-substitute and added kochi from Debian package.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/kochi-gothic/default.nix35
-rw-r--r--pkgs/data/fonts/kochi-mincho/default.nix35
-rw-r--r--pkgs/data/fonts/kochi-substitute/default.nix25
3 files changed, 70 insertions, 25 deletions
diff --git a/pkgs/data/fonts/kochi-gothic/default.nix b/pkgs/data/fonts/kochi-gothic/default.nix
new file mode 100644
index 000000000000..9c36da36bf6e
--- /dev/null
+++ b/pkgs/data/fonts/kochi-gothic/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchurl, dpkg }:
+
+let version = "20030809";
+in
+stdenv.mkDerivation {
+  name = "kochi-gothic-${version}";
+
+  src = fetchurl {
+    url = "mirror://debian/pool/main/t/ttf-kochi/ttf-kochi-gothic_${version}-15_all.deb";
+    sha256 = "6e2311cd8e880a9328e4d3eef34a1c1f024fc87fba0dce177a0e1584a7360fea";
+  };
+
+  buildInputs = [ dpkg ];
+
+  unpackCmd = ''
+    dpkg-deb --fsys-tarfile $src | tar xf - ./usr/share/fonts/truetype/kochi/kochi-gothic-subst.ttf
+  '';
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp ./share/fonts/truetype/kochi/kochi-gothic-subst.ttf $out/share/fonts/truetype/
+  '';
+
+  meta = {
+    description = "Japanese font, a free replacement for MS Gothic.";
+    longDescription = ''
+      Kochi Gothic was developed as a free replacement for the MS Gothic 
+      font from Microsoft. This is the Debian version of Kochi Gothic, which
+      removes some non-free glyphs that were added from the naga10 font.
+    '';
+    homepage = http://sourceforge.jp/projects/efont/;
+    license = stdenv.lib.licenses.wadalab;
+    maintainers = [ stdenv.lib.maintainers.auntie ];
+  };
+}
diff --git a/pkgs/data/fonts/kochi-mincho/default.nix b/pkgs/data/fonts/kochi-mincho/default.nix
new file mode 100644
index 000000000000..2f31b85220b9
--- /dev/null
+++ b/pkgs/data/fonts/kochi-mincho/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchurl, dpkg }:
+
+let version = "20030809";
+in
+stdenv.mkDerivation {
+  name = "kochi-mincho-${version}";
+
+  src = fetchurl {
+    url = "mirror://debian/pool/main/t/ttf-kochi/ttf-kochi-mincho_${version}-15_all.deb";
+    sha256 = "91ce6c993a3a0f77ed85db76f62ce18632b4c0cbd8f864676359a17ae5e6fa3c";
+  };
+
+  buildInputs = [ dpkg ];
+
+  unpackCmd = ''
+    dpkg-deb --fsys-tarfile $src | tar xf - ./usr/share/fonts/truetype/kochi/kochi-mincho-subst.ttf
+  '';
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp ./share/fonts/truetype/kochi/kochi-mincho-subst.ttf $out/share/fonts/truetype/
+  '';
+
+  meta = {
+    description = "Japanese font, a free replacement for MS Mincho.";
+    longDescription = ''
+      Kochi Mincho was developed as a free replacement for the MS Mincho 
+      font from Microsoft. This is the Debian version of Kochi Mincho, which
+      removes some non-free glyphs that were added from the naga10 font.
+    '';
+    homepage = http://sourceforge.jp/projects/efont/;
+    license = stdenv.lib.licenses.wadalab;
+    maintainers = [ stdenv.lib.maintainers.auntie ];
+  };
+}
diff --git a/pkgs/data/fonts/kochi-substitute/default.nix b/pkgs/data/fonts/kochi-substitute/default.nix
deleted file mode 100644
index 625955c444db..000000000000
--- a/pkgs/data/fonts/kochi-substitute/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ stdenv, fetchurl }:
-
-let version = "20030809";
-in
-stdenv.mkDerivation {
-  name = "kochi-substitute-${version}";
-
-  src = fetchurl {
-    url = "mirror://sourceforgejp/efont/5411/kochi-substitute-${version}.tar.bz2";
-    sha256 = "f4d69b24538833bf7e2c4de5e01713b3f1440960a6cc2a5993cb3c68cd23148c";
-  };
-
-  sourceRoot = "kochi-substitute-${version}";
-
-  installPhase =
-  ''
-    mkdir -p $out/share/fonts/kochi-substitute
-    cp *.ttf $out/share/fonts/kochi-substitute
-  '';
-
-  meta = {
-    description = "Japanese font, a free replacement for MS Gothic and MS Mincho.";
-    homepage = http://sourceforge.jp/projects/efont/;
-  };
-}