about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMichiel Leenaars <ml.software@leenaa.rs>2016-06-30 10:06:40 +0200
committerMichiel Leenaars <ml.software@leenaa.rs>2016-07-04 19:47:29 +0200
commitb8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756 (patch)
tree6422f8966fc8edcffc415728158384faa71e85da /pkgs/data
parent0967b0d303dc6fc297c25ec4885b7dd944f3bea3 (diff)
downloadnixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar.gz
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar.bz2
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar.lz
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar.xz
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.tar.zst
nixlib-b8fd2c9ecbf13ec8f73f726d5d79ee8724ea1756.zip
orbitron: init at 20110526
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/orbitron/default.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/pkgs/data/fonts/orbitron/default.nix b/pkgs/data/fonts/orbitron/default.nix
new file mode 100644
index 000000000000..d68bf37f4da8
--- /dev/null
+++ b/pkgs/data/fonts/orbitron/default.nix
@@ -0,0 +1,50 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "orbitron-${version}";
+  version = "20110526";
+
+  src = fetchFromGitHub {
+    owner  = "theleagueof";
+    repo   = "orbitron";
+    rev    = "13e6a52";
+    sha256 = "1c6jb7ayr07j1pbnzf3jxng9x9bbqp3zydf8mqdw9ifln1b4ycyf";
+  };
+
+  phases = [ "unpackPhase" "installPhase" ];
+
+  installPhase = ''
+    otfdir=$out/share/fonts/opentype/orbitron
+    ttfdir=$out/share/fonts/ttf/orbitron
+    mkdir -p $otfdir $ttfdir
+    cp -v Orbitron*.otf $otfdir
+    cp -v Orbitron*.ttf $ttfdir
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "https://www.theleagueofmoveabletype.com/orbitron";
+    downloadPage = "https://www.theleagueofmoveabletype.com/orbitron/download";
+    description = ''
+     Geometric sans-serif for display purposes by Matt McInerney'';
+    longDescription = ''
+     Orbitron is a geometric sans-serif typeface intended for display
+     purposes. It features four weights (light, medium, bold, and
+     black), a stylistic alternative, small caps, and a ton of
+     alternate glyphs.
+
+     Orbitron was designed so that graphic designers in the future
+     will have some alternative to typefaces like Eurostile or Bank
+     Gothic. If you’ve ever seen a futuristic sci-fi movie, you have
+     may noticed that all other fonts have been lost or destroyed in
+     the apocalypse that led humans to flee earth. Only those very few
+     geometric typefaces have survived to be used on spaceship
+     exteriors, space station signage, monopolistic corporate
+     branding, uniforms featuring aerodynamic shoulder pads, etc. Of
+     course Orbitron could also be used on the posters for the movies
+     portraying this inevitable future.
+    '';
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = [ maintainers.leenaars ];
+  };
+}