about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-01 18:01:03 +0000
committerGitHub <noreply@github.com>2023-12-01 18:01:03 +0000
commitb46f5c5c91b38a9488887bf5087e09fb69bc64b6 (patch)
tree75317d59f5a982c9addda3c887f47c2b7679122e /pkgs/data
parent9cca0e4288e48fa1e61dee5af425733afc4a882d (diff)
parent786100e12d24e50888986a553a26a60bbd484f01 (diff)
downloadnixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar.gz
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar.bz2
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar.lz
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar.xz
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.tar.zst
nixlib-b46f5c5c91b38a9488887bf5087e09fb69bc64b6.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/quivira/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/data/fonts/quivira/default.nix b/pkgs/data/fonts/quivira/default.nix
new file mode 100644
index 000000000000..8affc4f6c729
--- /dev/null
+++ b/pkgs/data/fonts/quivira/default.nix
@@ -0,0 +1,29 @@
+{ lib, fetchurl }:
+let
+  pname = "quivira";
+  version = "4.1";
+in fetchurl {
+  name = "${pname}-${version}";
+  url = "http://www.quivira-font.com/files/Quivira.otf";
+
+  # Download the source file to a temporary directory so that $out can be a
+  # directory with the expected structure.
+  downloadToTemp = true;
+  # recursiveHash needs to be true because $out is going to be a directory.
+  recursiveHash = true;
+  postFetch = ''
+    install -D $downloadedFile $out/share/fonts/opentype/Quivira.otf
+  '';
+
+  sha256 = "Hhl+0Oc5DDohOpBbEARMunMYCpr6nn4X6RgpQeEksNo=";
+  meta = {
+    description = "a free Unicode font in the OpenType format which is supported by every usual office program or printer";
+    homepage = "http://www.quivira-font.com/";
+    license = lib.licenses.publicDomain;
+    maintainers = [ lib.maintainers.nosewings ];
+    # From the homepage: "If you try to install Quivira on a Mac,
+    # you will get an error message about the 'post table
+    # usability'."
+    platforms = lib.filter (platform: !lib.hasInfix "darwin" platform) lib.platforms.all;
+  };
+}