about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-02-24 11:11:06 +0000
committerYegor Timoshenko <yegortimoshenko@riseup.net>2018-02-24 11:11:06 +0000
commitb22c33fb94a7f5f7a12edae8d1b79679612cf039 (patch)
tree2398b34a3e70f0cc2d2bbc80fa42a6976ec872ee /pkgs/data
parent5a22c587eb884387ea0a7b8ef7a5f68d01ab8c80 (diff)
downloadnixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar.gz
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar.bz2
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar.lz
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar.xz
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.tar.zst
nixlib-b22c33fb94a7f5f7a12edae8d1b79679612cf039.zip
elementary-xfce-icon-theme: refactor, build GTK icon cache
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/icons/elementary-xfce-icon-theme/default.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/pkgs/data/icons/elementary-xfce-icon-theme/default.nix b/pkgs/data/icons/elementary-xfce-icon-theme/default.nix
index 9ff54d5d64d5..063de059ee56 100644
--- a/pkgs/data/icons/elementary-xfce-icon-theme/default.nix
+++ b/pkgs/data/icons/elementary-xfce-icon-theme/default.nix
@@ -11,24 +11,21 @@ stdenv.mkDerivation rec {
     sha256 = "15n28f2pw8b0y5pi8ydahg31v6hhh7zvpvymi8jaafdc9bn18z3y";
   };
 
-  # fallback icon theme
-  propagatedBuildInputs = [ hicolor_icon_theme ];
-
-  dontBuild = true;
+  nativeBuildInputs = [ gtk3 hicolor_icon_theme ];
 
   installPhase = ''
-    install -dm 755 $out/share/icons
-    cp -dr --no-preserve='ownership' elementary-xfce{,-dark,-darker,-darkest} $out/share/icons/
+    mkdir -p $out/share/icons
+    mv elementary-xfce* $out/share/icons
   '';
 
-  postInstall = ''
-    for icons in "$out"/share/icons/*; do
-      "${gtk3.out}/bin/gtk-update-icon-cache" "$icons"
+  postFixup = ''
+    for theme in $out/share/icons/*; do
+      gtk-update-icon-cache $theme
     done
   '';
 
   meta = with stdenv.lib; {
-    description = "Elementary icons for Xfce and other Gtk+ desktops like Gnome3";
+    description = "Elementary icons for Xfce and other GTK+ desktops like GNOME";
     homepage = https://github.com/shimmerproject/elementary-xfce;
     license = licenses.gpl2;
     platforms = platforms.unix;