about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2022-02-05 00:08:46 +0000
committerGitHub <noreply@github.com>2022-02-05 00:08:46 +0000
commitae333b719ea62ddb01c0431a6580382778ebe88c (patch)
tree45d8421a6efe60f95e986660c3e2b8e3724ae921 /pkgs/data
parent7ef2b7a3502a1ca4a7994dc04afce106e25e0213 (diff)
parent438ec49e5238f615169490b87737f691e0acf461 (diff)
downloadnixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar.gz
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar.bz2
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar.lz
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar.xz
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.tar.zst
nixlib-ae333b719ea62ddb01c0431a6580382778ebe88c.zip
Merge master into haskell-updates
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/themes/graphite-kde-theme/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/data/themes/graphite-kde-theme/default.nix b/pkgs/data/themes/graphite-kde-theme/default.nix
new file mode 100644
index 000000000000..b402c29922b0
--- /dev/null
+++ b/pkgs/data/themes/graphite-kde-theme/default.nix
@@ -0,0 +1,41 @@
+{ stdenv
+, lib
+, fetchFromGitHub
+}:
+
+stdenv.mkDerivation rec {
+  pname = "graphite-kde-theme";
+  version = "unstable-2022-01-22";
+
+  src = fetchFromGitHub {
+    owner = "vinceliuice";
+    repo = pname;
+    rev = "d60a26533b104d6d2251c5187a402f3f35ecbdf7";
+    sha256 = "0cry5s3wr0frpchc0hx97r9v6r3v6rvln7l1hb3znn8npkr4mssi";
+  };
+
+  installPhase = ''
+    runHook preInstall
+
+    patchShebangs install.sh
+
+    substituteInPlace install.sh \
+      --replace '$HOME/.local' $out \
+      --replace '$HOME/.config' $out/share
+
+    name= ./install.sh --dest $out/share/themes
+
+    mkdir -p $out/share/sddm/themes
+    cp -a sddm/Graphite $out/share/sddm/themes/
+
+    runHook postInstall
+  '';
+
+  meta = with lib; {
+    description = "A flat Design theme for KDE Plasma desktop";
+    homepage = "https://github.com/vinceliuice/Graphite-kde-theme";
+    license = licenses.gpl3Only;
+    platforms = platforms.all;
+    maintainers = [ maintainers.romildo ];
+  };
+}