about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorLangston Barrett <langston.barrett@gmail.com>2017-09-25 20:35:35 +0000
committerLangston Barrett <langston.barrett@gmail.com>2017-09-25 20:38:05 +0000
commit91983a3f2565d6c0a0daffc120048106247f8ba8 (patch)
treeaebefd7b020ddb3540b88714253decfea7ea838b /pkgs/data
parentd757d8142e88187388fbea4e884feadb0e33d36f (diff)
downloadnixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar.gz
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar.bz2
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar.lz
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar.xz
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.tar.zst
nixlib-91983a3f2565d6c0a0daffc120048106247f8ba8.zip
latinmodern-math: init at 1.959
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/lm-math/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/data/fonts/lm-math/default.nix b/pkgs/data/fonts/lm-math/default.nix
new file mode 100644
index 000000000000..348373b89276
--- /dev/null
+++ b/pkgs/data/fonts/lm-math/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchzip }:
+
+stdenv.mkDerivation rec {
+  name = "latinmodern-math-${version}";
+  version = "1.959";
+
+  src = fetchzip {
+    url = "www.gust.org.pl/projects/e-foundry/lm-math/download/latinmodern-math-1959.zip";
+    sha256 = "15l3lxjciyjmbh0q6jjvzz16ibk4ij79in9fs47qhrfr2wrddpvs";
+  };
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype/
+    mkdir -p $out/share/doc/${name}/
+    cp otf/*.otf $out/share/fonts/opentype/
+    cp doc/*.txt $out/share/doc/${name}/
+  '';
+
+  outputHashAlgo = "sha256";
+  outputHashMode = "recursive";
+  outputHash = "05k145bxgxjh7i9gx1ahigxfpc2v2vwzsy2mc41jvvg51kjr8fnn";
+
+  meta = with stdenv.lib; {
+    description = "The Latin Modern Math (LM Math) font completes the modernization of the Computer Modern family of typefaces designed and programmed by Donald E. Knuth.";
+    homepage = http://www.gust.org.pl/projects/e-foundry/lm-math;
+    # "The Latin Modern Math font is licensed under the GUST Font License (GFL),
+    # which is a free license, legally equivalent to the LaTeX Project Public
+    # License (LPPL), version 1.3c or later." - GUST website
+    license = licenses.lppl13c;
+    maintainers = with maintainers; [ siddharthist ];
+    platforms = platforms.all;
+  };
+}