about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2014-05-26 14:55:32 -0500
committerThomas Tuegel <ttuegel@gmail.com>2014-07-08 15:59:34 -0500
commit88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d (patch)
tree091b7735ba6e5a9db8dd90614c8689af1d2d23fa /pkgs/data
parent873832ab6db5bafaaa9070ab5c0dacca551d062c (diff)
downloadnixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar.gz
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar.bz2
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar.lz
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar.xz
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.tar.zst
nixlib-88f60ee57d6a0de7cb77333d9189c3d7c06d7f3d.zip
Add source-sans-pro-1.050
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/source-sans-pro/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/data/fonts/source-sans-pro/default.nix b/pkgs/data/fonts/source-sans-pro/default.nix
new file mode 100644
index 000000000000..eccddc8f14c0
--- /dev/null
+++ b/pkgs/data/fonts/source-sans-pro/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation {
+  name = "source-sans-pro-1.050";
+  src = fetchurl {
+    url = "mirror://sourceforge/sourcesans.adobe/SourceSansPro_FontsOnly-1.050.zip";
+    sha256 = "002z7kx8jxp5pfrilqaxbwbr5yp9fl3zsp0imawmf5wqagpzayf3";
+  };
+
+  buildInputs = [ unzip ];
+
+  phases = "unpackPhase installPhase";
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype
+    find . -name "*.otf" -exec cp {} $out/share/fonts/opentype \;
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://sourceforge.net/adobe/sourcesans;
+    description = "A set of OpenType fonts designed by Adobe for UIs";
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ ttuegel ];
+  };
+}