about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMichael Alyn Miller <malyn@strangeGizmo.com>2015-04-20 20:18:40 -0700
committerMichael Alyn Miller <malyn@strangeGizmo.com>2015-04-24 07:33:59 -0700
commit76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120 (patch)
treeb75d97f2569bead40bf86764b027ee2d01acfacb /pkgs/data
parentff6be09c2e2d7f2127f81296d812e325fd0b51fb (diff)
downloadnixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar.gz
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar.bz2
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar.lz
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar.xz
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.tar.zst
nixlib-76dcf48b13c27b7a2fc2373e2bf2e2e1e95ab120.zip
Add Powerline fonts
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/powerline-fonts/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/data/fonts/powerline-fonts/default.nix b/pkgs/data/fonts/powerline-fonts/default.nix
new file mode 100644
index 000000000000..0d3d9c104d46
--- /dev/null
+++ b/pkgs/data/fonts/powerline-fonts/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation {
+  name = "powerline-fonts-2014-12-27";
+
+  src = fetchFromGitHub {
+    owner = "powerline";
+    repo = "fonts";
+    rev = "39c99c02652f25290b64e24a7e9a7cfb8ce89a3e";
+    sha256 = "9c83a30f36dc980582c0a079bd2896f95d19e1cb0ba5afbd8cae936c944256dd";
+  };
+
+  buildPhase = "true";
+
+  installPhase =
+    ''
+      mkdir -p $out/share/fonts/opentype
+      cp -v */*.otf $out/share/fonts/opentype
+
+      mkdir -p $out/share/fonts/truetype
+      cp -v */*.ttf $out/share/fonts/truetype
+    '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/powerline/fonts;
+    description = "Patched fonts for Powerline users.";
+    longDescription = ''
+      Pre-patched and adjusted fonts for usage with the Powerline plugin.
+    '';
+    license = "asl20 free ofl";
+    platforms = platforms.all;
+    maintainer = with maintainers; [ malyn ];
+  };
+}