about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-11-23 00:12:55 +0000
committerGitHub <noreply@github.com>2023-11-23 00:12:55 +0000
commit6200bfcd4220da915bb1b4fa178962825bfd7e91 (patch)
tree0fce1288f050e4bed4b1eeb1d811395defca3d54 /pkgs/data
parent1ccaf0c1471adc88c2eade131f30ef21a2feaeda (diff)
parentc10d7026fbae24c51e87586c6b6e4c46c0365007 (diff)
downloadnixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar.gz
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar.bz2
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar.lz
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar.xz
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.tar.zst
nixlib-6200bfcd4220da915bb1b4fa178962825bfd7e91.zip
Merge master into haskell-updates
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/spleen/default.nix4
-rw-r--r--pkgs/data/misc/v2ray-domain-list-community/default.nix4
-rw-r--r--pkgs/data/themes/colloid-kde/default.nix29
-rw-r--r--pkgs/data/themes/graphite-gtk-theme/default.nix6
-rw-r--r--pkgs/data/themes/graphite-kde-theme/default.nix33
-rw-r--r--pkgs/data/themes/layan-kde/default.nix20
-rw-r--r--pkgs/data/themes/qogir-kde/default.nix20
-rw-r--r--pkgs/data/themes/whitesur-kde/default.nix20
8 files changed, 110 insertions, 26 deletions
diff --git a/pkgs/data/fonts/spleen/default.nix b/pkgs/data/fonts/spleen/default.nix
index 55b88c961392..0c114b176abd 100644
--- a/pkgs/data/fonts/spleen/default.nix
+++ b/pkgs/data/fonts/spleen/default.nix
@@ -2,11 +2,11 @@
 
 stdenvNoCC.mkDerivation rec {
   pname = "spleen";
-  version = "2.0.0";
+  version = "2.0.1";
 
   src = fetchurl {
     url = "https://github.com/fcambus/spleen/releases/download/${version}/spleen-${version}.tar.gz";
-    hash = "sha256-d4d4s13UhwG4A9skemrIdZFUzl/Dq9XMC225ikS6Wgw=";
+    hash = "sha256-N9kJrWaQN9eeNoOVJu9UN2+jcEbHqRWxV+X0DXNJLuA=";
   };
 
   nativeBuildInputs = [ xorg.mkfontscale ];
diff --git a/pkgs/data/misc/v2ray-domain-list-community/default.nix b/pkgs/data/misc/v2ray-domain-list-community/default.nix
index bc4aaf72ae9e..bac9d4bd7e60 100644
--- a/pkgs/data/misc/v2ray-domain-list-community/default.nix
+++ b/pkgs/data/misc/v2ray-domain-list-community/default.nix
@@ -3,12 +3,12 @@
 let
   generator = pkgsBuildBuild.buildGoModule rec {
     pname = "v2ray-domain-list-community";
-    version = "20231118232758";
+    version = "20231121082246";
     src = fetchFromGitHub {
       owner = "v2fly";
       repo = "domain-list-community";
       rev = version;
-      hash = "sha256-m4B1O8h6lRxArEyuE4XUF9eJtoBhl59QNXkVjWKx2ko=";
+      hash = "sha256-wES4u1CYV3oO+KrIePJRhFqyWeiMCvn9lIhCtlaujlg=";
     };
     vendorHash = "sha256-6167kRAC5m5FlBr7uk+qKUcjWsb45P5Vvovyb6hHSVQ=";
     meta = with lib; {
diff --git a/pkgs/data/themes/colloid-kde/default.nix b/pkgs/data/themes/colloid-kde/default.nix
index 8c2dcb8a8738..24cde3f38989 100644
--- a/pkgs/data/themes/colloid-kde/default.nix
+++ b/pkgs/data/themes/colloid-kde/default.nix
@@ -1,26 +1,45 @@
 { lib
 , stdenvNoCC
 , fetchFromGitHub
+, kdeclarative
+, plasma-framework
+, plasma-workspace
 , gitUpdater
 }:
 
 stdenvNoCC.mkDerivation rec {
   pname = "colloid-kde";
-  version = "unstable-2022-07-13";
+  version = "unstable-2023-07-04";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = pname;
-    rev = "eaf6844e997aa60c755af7ea560ffba798e72ff5";
-    hash = "sha256-FNTG5aVvTWHqNVVR23LFG/ykPtXRD7oH5C6eyWaqc60=";
+    rev = "0b79befdad9b442b5a8287342c4b7e47ff87d555";
+    hash = "sha256-AYH9fW20/p+mq6lxR1lcCV1BQ/kgcsjHncpMvYWXnWA=";
   };
 
+  # Propagate sddm theme dependencies to user env otherwise sddm does
+  # not find them. Putting them in buildInputs is not enough.
+  propagatedUserEnvPkgs = [
+    kdeclarative.bin
+    plasma-framework
+    plasma-workspace
+  ];
+
   postPatch = ''
     patchShebangs install.sh
 
     substituteInPlace install.sh \
       --replace '$HOME/.local' $out \
       --replace '$HOME/.config' $out/share
+
+    substituteInPlace sddm/install.sh \
+      --replace /usr $out \
+      --replace '$(cd $(dirname $0) && pwd)' . \
+      --replace '"$UID" -eq "$ROOT_UID"' true
+
+    substituteInPlace sddm/Colloid/Main.qml \
+      --replace /usr $out
   '';
 
   installPhase = ''
@@ -31,6 +50,10 @@ stdenvNoCC.mkDerivation rec {
     name= HOME="$TMPDIR" \
     ./install.sh --dest $out/share/themes
 
+    mkdir -p $out/share/sddm/themes
+    cd sddm
+    source install.sh
+
     runHook postInstall
   '';
 
diff --git a/pkgs/data/themes/graphite-gtk-theme/default.nix b/pkgs/data/themes/graphite-gtk-theme/default.nix
index b59b1393c6d8..46cceaa23ba4 100644
--- a/pkgs/data/themes/graphite-gtk-theme/default.nix
+++ b/pkgs/data/themes/graphite-gtk-theme/default.nix
@@ -27,13 +27,13 @@ lib.checkListOfEnum "${pname}: grub screens" [ "1080p" "2k" "4k" ] grubScreens
 
 stdenvNoCC.mkDerivation rec {
   inherit pname;
-  version = "2023-05-17";
+  version = "unstable-2023-11-22";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = pname;
-    rev = version;
-    sha256 = "hymOqtwMk6Yja5le6ADZl04yjbOJjhairiH7a4m7gMk=";
+    rev = "429645480653e2e3b3d003d9afcebf075769db2b";
+    sha256 = "sha256-2MPAyod4kPlj/eJiYRsS3FJL0pUR+o9W4CSbI6M3350=";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/data/themes/graphite-kde-theme/default.nix b/pkgs/data/themes/graphite-kde-theme/default.nix
index dd3a215a0385..d098cf6aab45 100644
--- a/pkgs/data/themes/graphite-kde-theme/default.nix
+++ b/pkgs/data/themes/graphite-kde-theme/default.nix
@@ -1,36 +1,55 @@
 { stdenv
 , lib
 , fetchFromGitHub
+, kdeclarative
+, plasma-framework
+, plasma-workspace
+, gitUpdater
 }:
 
 stdenv.mkDerivation rec {
   pname = "graphite-kde-theme";
-  version = "2022-02-08";
+  version = "unstable-2023-10-25";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = pname;
-    rev = version;
-    sha256 = "0pnn5s1vfdgkpsy5sc838731ly1imi8pbyd4asibw4zi238l0nvf";
+    rev = "33cc85c49c424dfcba73e6ee84b0dc7fb9e52566";
+    hash = "sha256-iQGT2x0wY2EIuYw/a1MB8rT9BxiqWrOyBo6EGIJwsFw=";
   };
 
-  installPhase = ''
-    runHook preInstall
+  # Propagate sddm theme dependencies to user env otherwise sddm does
+  # not find them. Putting them in buildInputs is not enough.
+  propagatedUserEnvPkgs = [
+    kdeclarative.bin
+    plasma-framework
+    plasma-workspace
+  ];
 
+  postPatch = ''
     patchShebangs install.sh
 
     substituteInPlace install.sh \
       --replace '$HOME/.local' $out \
       --replace '$HOME/.config' $out/share
 
-    name= ./install.sh --dest $out/share/themes
+    substituteInPlace sddm/*/Main.qml \
+      --replace /usr $out
+  '';
+
+  installPhase = ''
+    runHook preInstall
+
+    name= ./install.sh
 
     mkdir -p $out/share/sddm/themes
-    cp -a sddm/Graphite $out/share/sddm/themes/
+    cp -a sddm/Graphite* $out/share/sddm/themes/
 
     runHook postInstall
   '';
 
+  passthru.updateScript = gitUpdater { };
+
   meta = with lib; {
     description = "A flat Design theme for KDE Plasma desktop";
     homepage = "https://github.com/vinceliuice/Graphite-kde-theme";
diff --git a/pkgs/data/themes/layan-kde/default.nix b/pkgs/data/themes/layan-kde/default.nix
index 3b030337b7bc..7ca55d1dc74f 100644
--- a/pkgs/data/themes/layan-kde/default.nix
+++ b/pkgs/data/themes/layan-kde/default.nix
@@ -1,26 +1,40 @@
 { stdenv
 , lib
 , fetchFromGitHub
+, kdeclarative
+, plasma-framework
+, plasma-workspace
 , gitUpdater
 }:
 
 stdenv.mkDerivation rec {
   pname = "layan-kde";
-  version = "2022-02-13";
+  version = "unstable-2023-09-30";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = pname;
-    rev = version;
-    sha256 = "09z90g13l26v23nwr8n5bapwldp3hhdrdikynvm4vvb7qsvb4vrp";
+    rev = "7ab7cd7461dae8d8d6228d3919efbceea5f4272c";
+    hash = "sha256-Wh8tZcQEdTTlgtBf4ovapojHcpPBZDDkWOclmxZv9zA=";
   };
 
+  # Propagate sddm theme dependencies to user env otherwise sddm does
+  # not find them. Putting them in buildInputs is not enough.
+  propagatedUserEnvPkgs = [
+    kdeclarative.bin
+    plasma-framework
+    plasma-workspace
+  ];
+
   postPatch = ''
     patchShebangs install.sh
 
     substituteInPlace install.sh \
       --replace '$HOME/.local' $out \
       --replace '$HOME/.config' $out/share
+
+    substituteInPlace sddm/*/Main.qml \
+      --replace /usr $out
   '';
 
   installPhase = ''
diff --git a/pkgs/data/themes/qogir-kde/default.nix b/pkgs/data/themes/qogir-kde/default.nix
index 44182aa3f45a..1dd3deba8dff 100644
--- a/pkgs/data/themes/qogir-kde/default.nix
+++ b/pkgs/data/themes/qogir-kde/default.nix
@@ -1,26 +1,40 @@
 { lib
 , stdenvNoCC
 , fetchFromGitHub
+, kdeclarative
+, plasma-framework
+, plasma-workspace
 , gitUpdater
 }:
 
 stdenvNoCC.mkDerivation rec {
   pname = "qogir-kde";
-  version = "unstable-2022-07-08";
+  version = "unstable-2023-10-20";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = pname;
-    rev = "f240eae10978c7fee518f7a8be1c41a21a9d5c2e";
-    hash = "sha256-AV60IQWwgvLwDO3ylILwx1DkKadwo4isn3JX3WpKoxQ=";
+    rev = "1cfe8da54e6f76d5ce0d2234dcb4f5186431edb3";
+    hash = "sha256-Ts8cS7dH8RkfRgWvzDKLCC2G6Hsnvx0NAGstfxMIt+Y=";
   };
 
+  # Propagate sddm theme dependencies to user env otherwise sddm does
+  # not find them. Putting them in buildInputs is not enough.
+  propagatedUserEnvPkgs = [
+    kdeclarative.bin
+    plasma-framework
+    plasma-workspace
+  ];
+
   postPatch = ''
     patchShebangs install.sh
 
     substituteInPlace install.sh \
       --replace '$HOME/.local' $out \
       --replace '$HOME/.config' $out/share
+
+    substituteInPlace sddm/*/Main.qml \
+      --replace /usr $out
   '';
 
   installPhase = ''
diff --git a/pkgs/data/themes/whitesur-kde/default.nix b/pkgs/data/themes/whitesur-kde/default.nix
index 2e98b4165c07..20dc5a66fe5e 100644
--- a/pkgs/data/themes/whitesur-kde/default.nix
+++ b/pkgs/data/themes/whitesur-kde/default.nix
@@ -1,20 +1,31 @@
 { lib
 , stdenvNoCC
 , fetchFromGitHub
+, kdeclarative
+, plasma-framework
+, plasma-workspace
 , gitUpdater
 }:
 
 stdenvNoCC.mkDerivation (finalAttrs: {
   pname = "whitesur-kde";
-  version = "unstable-2023-08-15";
+  version = "unstable-2023-10-06";
 
   src = fetchFromGitHub {
     owner = "vinceliuice";
     repo = finalAttrs.pname;
-    rev = "d50bc20b2b78705bb9856204066affb763fa8a35";
-    hash = "sha256-oG6QT4VQpBznM+gvzdiY4CldOwdHcBeHlbvlc52eFuU=";
+    rev = "2b4bcc76168bd8a4a7601188e177fa0ab485cdc8";
+    hash = "sha256-+Iooj8a7zfLhEWnjLEVoe/ebD9Vew5HZdz0wpWVZxA8=";
   };
 
+  # Propagate sddm theme dependencies to user env otherwise sddm does
+  # not find them. Putting them in buildInputs is not enough.
+  propagatedUserEnvPkgs = [
+    kdeclarative.bin
+    plasma-framework
+    plasma-workspace
+  ];
+
   postPatch = ''
     patchShebangs install.sh
 
@@ -22,6 +33,9 @@ stdenvNoCC.mkDerivation (finalAttrs: {
       --replace '$HOME/.config' $out/share \
       --replace '$HOME/.local' $out \
       --replace '"$HOME"/.Xresources' $out/doc/.Xresources
+
+    substituteInPlace sddm/*/Main.qml \
+      --replace /usr $out
   '';
 
   installPhase = ''