about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMichiel Leenaars <ml.software@leenaa.rs>2018-08-20 01:43:55 +0200
committerMichiel Leenaars <ml.software@leenaa.rs>2018-08-20 01:44:39 +0200
commit55570268f228b5f6c29f65c14f2c103da9d16da9 (patch)
tree7b5c99a08c0db6face7b60a84d8c64b8c80d1f6a /pkgs/data
parentea51558cfad3c74cdf49afe9ca62033438877abe (diff)
downloadnixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar.gz
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar.bz2
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar.lz
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar.xz
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.tar.zst
nixlib-55570268f228b5f6c29f65c14f2c103da9d16da9.zip
f5_6-font: init at 0.110
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/f5_6/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/data/fonts/f5_6/default.nix b/pkgs/data/fonts/f5_6/default.nix
new file mode 100644
index 000000000000..25cab717cee9
--- /dev/null
+++ b/pkgs/data/fonts/f5_6/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "110";
+  pname = "f5_6";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "04p6lccd26rhjbpq3ddxi5vkk3lk8lqbpnk8lakjzixp3fgdqpp4";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/${pname}/";
+    description = "A weighted decorative font.";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}