about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorgnidorah <gnidorah@users.noreply.github.com>2020-06-01 14:39:08 +0300
committergnidorah <gnidorah@users.noreply.github.com>2020-06-01 14:39:08 +0300
commit51a244259cce1c944ac8af50f213da087499e689 (patch)
treea8be3461af5274ea4c6f7798119efa6a067e8293 /pkgs/data
parent46f975f81e0f71ba0d2b2bb8fe4006a9aa4c6c5c (diff)
downloadnixlib-51a244259cce1c944ac8af50f213da087499e689.tar
nixlib-51a244259cce1c944ac8af50f213da087499e689.tar.gz
nixlib-51a244259cce1c944ac8af50f213da087499e689.tar.bz2
nixlib-51a244259cce1c944ac8af50f213da087499e689.tar.lz
nixlib-51a244259cce1c944ac8af50f213da087499e689.tar.xz
nixlib-51a244259cce1c944ac8af50f213da087499e689.tar.zst
nixlib-51a244259cce1c944ac8af50f213da087499e689.zip
cde-gtk-theme: init at 1.3
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/themes/cde-motif-theme/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/data/themes/cde-motif-theme/default.nix b/pkgs/data/themes/cde-motif-theme/default.nix
new file mode 100644
index 000000000000..cc83047e3cce
--- /dev/null
+++ b/pkgs/data/themes/cde-motif-theme/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, python2Packages }:
+
+stdenv.mkDerivation rec {
+  pname = "cde-motif-theme";
+  version = "1.3";
+
+  src = fetchFromGitHub {
+    owner = "josvanr";
+    repo = "cde-motif-theme";
+    rev = version;
+    sha256 = "1v5c4db69cmzdci8xxlkx3s3cifg1h5160qq5siwfps0sj7pvggj";
+  };
+
+  dontBuild = true;
+
+  pythonPath = with python2Packages; [ pyqt4 pillow pyxdg pyyaml ];
+  nativeBuildInputs = with python2Packages; [ python wrapPython ];
+
+  installPhase = ''
+    mkdir -p $out/share/themes
+    cp -r cdetheme $out/share/themes
+    patchShebangs $out/share/themes/cdetheme/scripts/switchtheme
+    wrapPythonProgramsIn "$out/share/themes/cdetheme/scripts" "$out $pythonPath"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Gtk2 / Gtk3 theme mimicking CDE / Motif";
+    homepage = "https://www.gnome-look.org/p/1231025";
+    license = licenses.gpl3;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ gnidorah ];
+  };
+}