about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2016-06-10 10:25:14 -0300
committerChristoph Hrdinka <c.git@hrdinka.at>2016-06-13 09:40:43 +0200
commit4e44a330cb0ee3a13ee2372293fedf54f354b66e (patch)
tree3b696897f1453c3274a5dcd56ce4a7455a90a693 /pkgs/data
parentc33cf023374050f6c3a70cc34d83256b6f1bc544 (diff)
downloadnixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar.gz
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar.bz2
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar.lz
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar.xz
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.tar.zst
nixlib-4e44a330cb0ee3a13ee2372293fedf54f354b66e.zip
moka-icon-theme: init at 2016-06-07
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/icons/moka-icon-theme/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/data/icons/moka-icon-theme/default.nix b/pkgs/data/icons/moka-icon-theme/default.nix
new file mode 100644
index 000000000000..4d98a50c0c4b
--- /dev/null
+++ b/pkgs/data/icons/moka-icon-theme/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, faba-icon-theme }:
+
+stdenv.mkDerivation rec {
+  name = "${package-name}-${version}";
+  package-name = "moka-icon-theme";
+  version = "2016-06-07";
+
+  src = fetchFromGitHub {
+    owner = "moka-project";
+    repo = package-name;
+    rev = "a03d14e30dbdf05e8ea904994b8081ad0824e155";
+    sha256 = "1j1cnrrg0gfr4vfzxlabrv8090fg4yni99g61s82vnyszkiy1rcm";
+  };
+
+  nativeBuildInputs = [ autoreconfHook ];
+
+  buildInputs = [ faba-icon-theme ];
+
+  postPatch = ''
+    substituteInPlace Makefile.am --replace '$(DESTDIR)'/usr $out
+  '';
+
+  meta = with stdenv.lib; {
+    description = "An icon theme designed with a minimal flat style using simple geometry and bright colours";
+    homepage = https://snwh.org/moka;
+    license = with licenses; [ cc-by-sa-40 gpl3 ];
+    platforms = platforms.all;
+    maintainers = with maintainers; [ romildo ];
+  };
+}