about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-12-19 15:55:44 +0100
committerGitHub <noreply@github.com>2018-12-19 15:55:44 +0100
commit433b867b61d6012dacdb35fba5ad6b69bfec81d0 (patch)
tree19c15a299496d8ae06c4bd683bd8350aa8de9ac9 /pkgs/data
parent7e5667926e74c212130bdc829c784ab962612224 (diff)
parent91e1e2fd9267feaae70bf3f26289b58cbb9713fc (diff)
downloadnixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar.gz
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar.bz2
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar.lz
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar.xz
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.tar.zst
nixlib-433b867b61d6012dacdb35fba5ad6b69bfec81d0.zip
Merge pull request #52520 from romildo/upd.plano-theme
plano-theme: 3.28-3 -> 3.30-1
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/themes/plano/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/data/themes/plano/default.nix b/pkgs/data/themes/plano/default.nix
new file mode 100644
index 000000000000..f876fbb933b4
--- /dev/null
+++ b/pkgs/data/themes/plano/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, gdk_pixbuf, gtk_engines, gtk-engine-murrine }:
+
+stdenv.mkDerivation rec {
+  name = "plano-theme-${version}";
+  version = "3.30-1";
+
+  src = fetchFromGitHub {
+    owner = "lassekongo83";
+    repo = "plano-theme";
+    rev = "v${version}";
+    sha256 = "152iqfhwxmxx817n05j603263nbmry626zxq8hiljww8zpmqh8j2";
+  };
+
+  buildInputs = [ gdk_pixbuf gtk_engines ];
+
+  propagatedUserEnvPkgs = [ gtk-engine-murrine ];
+
+  dontBuild = true;
+
+  installPhase = ''
+    install -dm 755 $out/share/themes/Plano
+    cp -a * $out/share/themes/Plano/
+    rm $out/share/themes/Plano/LICENSE
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Flat theme for GNOME & Xfce4";
+    homepage = https://github.com/lassekongo83/plano-theme;
+    license = licenses.gpl3;
+    platforms = platforms.unix;
+    maintainers = [ maintainers.romildo ];
+  };
+}