about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorJosé Romildo <malaquias@gmail.com>2023-11-16 17:20:01 -0300
committerJosé Romildo <malaquias@gmail.com>2023-11-17 14:51:00 -0300
commit41c836ad8e09696da42deadc6e95bfb2b089d712 (patch)
treecf0377aa42a5b58ffcc84fcee58ea03e24d04ea8 /pkgs/data
parentd28775dde5684dd625a8ffdb89dbb10329154393 (diff)
downloadnixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar.gz
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar.bz2
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar.lz
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar.xz
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.tar.zst
nixlib-41c836ad8e09696da42deadc6e95bfb2b089d712.zip
papirus-icon-theme: add withElementary optional argument
Upstream advices to make optional the installation of ePapirus and
ePapirus-Dark icon themes, in order to reduce inodes and package
size. Those themes are recommended for the ElementaryOS and Pantheon desktop
environments.

Therefore papirus-icon-theme does not include ePapirus* anymore. But
the new epapirus-icon-theme includes all of them, and is suitable for
use with ElementaryOS or Pantheon.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/icons/papirus-icon-theme/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/data/icons/papirus-icon-theme/default.nix b/pkgs/data/icons/papirus-icon-theme/default.nix
index 5b037a82269d..41af47eca5db 100644
--- a/pkgs/data/icons/papirus-icon-theme/default.nix
+++ b/pkgs/data/icons/papirus-icon-theme/default.nix
@@ -2,12 +2,12 @@
 , stdenvNoCC
 , fetchFromGitHub
 , gtk3
-, pantheon
 , breeze-icons
-, gnome-icon-theme
+, elementary-icon-theme
 , hicolor-icon-theme
 , papirus-folders
 , color ? null
+, withElementary ? false
 , gitUpdater
 }:
 
@@ -28,10 +28,10 @@ stdenvNoCC.mkDerivation rec {
   ];
 
   propagatedBuildInputs = [
-    pantheon.elementary-icon-theme
     breeze-icons
-    gnome-icon-theme
     hicolor-icon-theme
+  ] ++ lib.optional withElementary [
+    elementary-icon-theme
   ];
 
   dontDropIconThemeCache = true;
@@ -40,7 +40,7 @@ stdenvNoCC.mkDerivation rec {
     runHook preInstall
 
     mkdir -p $out/share/icons
-    mv {,e}Papirus* $out/share/icons
+    mv ${lib.optionalString withElementary "{,e}"}Papirus* $out/share/icons
 
     for theme in $out/share/icons/*; do
       ${lib.optionalString (color != null) "${papirus-folders}/bin/papirus-folders -t $theme -o -C ${color}"}