about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorcillianderoiste <cillian.deroiste@gmail.com>2014-09-13 15:56:56 +0200
committercillianderoiste <cillian.deroiste@gmail.com>2014-09-13 15:56:56 +0200
commit3bb60dbefeb0a869246fc75761ece8425d78847b (patch)
tree0ed89b4ac34573455930ba7d0cd05b7cd5d4845b /pkgs/data
parentf6d4d5907ec6f1dafff3b14d262f16f96f8ed6a0 (diff)
parente68d97aa43e0fd3a6643ec1ba339ff6570aeeb1b (diff)
downloadnixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar.gz
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar.bz2
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar.lz
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar.xz
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.tar.zst
nixlib-3bb60dbefeb0a869246fc75761ece8425d78847b.zip
Merge pull request #4060 from rycee/stix-font
 Add package for the STIX OTF fonts.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/stix-otf/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/data/fonts/stix-otf/default.nix b/pkgs/data/fonts/stix-otf/default.nix
new file mode 100644
index 000000000000..f32d865c95c7
--- /dev/null
+++ b/pkgs/data/fonts/stix-otf/default.nix
@@ -0,0 +1,30 @@
+{stdenv, fetchurl, unzip}:
+
+stdenv.mkDerivation rec {
+  name = "stix-otf-${version}";
+  version = "1.1.1";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/stixfonts/STIXv${version}-word.zip";
+    sha256 = "1q35wbqn3nh78pdban9z37lh090c6p49q3d00zzxm0axxz66xy4q";
+  };
+
+  buildInputs = [unzip];
+
+  phases = ["unpackPhase" "installPhase"];
+
+  sourceRoot = "Fonts/STIX-Word";
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype
+    cp *.otf $out/share/fonts/opentype
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://www.stixfonts.org/;
+    description = "Fonts for Scientific and Technical Information eXchange";
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = [maintainers.rycee];
+  };
+}