about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorAlexander V. Nikolaev <avn@daemon.hole.ru>2015-09-21 12:25:39 +0300
committerAlexander V. Nikolaev <avn@daemon.hole.ru>2015-09-23 23:43:50 +0300
commit3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01 (patch)
tree95ae5763975b41d64cf80d62c5b340b182f6e1ad /pkgs/data
parentd9b4d81a39d70fc481e86bcfa3362d32a3578b44 (diff)
downloadnixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar.gz
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar.bz2
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar.lz
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar.xz
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.tar.zst
nixlib-3973f9f2fe8b3b5d506cddc4a9dafe8cc1155b01.zip
inconsolata-lgc: init at 2015-04-18
Add Inconsolata-LGC, fork of Inconsolata font with improved Cyrillic
and Greek support.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/inconsolata/lgc.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/pkgs/data/fonts/inconsolata/lgc.nix b/pkgs/data/fonts/inconsolata/lgc.nix
new file mode 100644
index 000000000000..ffa55a33e8e0
--- /dev/null
+++ b/pkgs/data/fonts/inconsolata/lgc.nix
@@ -0,0 +1,59 @@
+{stdenv, fetchFromGitHub, fontforge}:
+
+stdenv.mkDerivation rec {
+  name = "inconsolata-lgc-${version}";
+  version = "git-2015-04-18";
+
+  src = fetchFromGitHub {
+    owner = "MihailJP";
+    repo = "Inconsolata-LGC";
+    rev = "30bbc1bd82502bf76f1cc5553f17388da2ba20e7";
+    sha256 = "02af2gpksdxdp7zfh5qhgfqzc6gvah9v4ph818irwhs9gcq8833c";
+  };
+
+  buildInputs = [ fontforge ];
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp -v $(find . -name '*.ttf') $out/share/fonts/truetype
+
+    mkdir -p $out/share/fonts/opentype
+    cp -v $(find . -name '*.otf') $out/share/fonts/opentype
+
+    mkdir -p "$out/doc/${name}"
+    cp -v AUTHORS ChangeLog COPYING License.txt README "$out/doc/${name}" || true
+  '';
+
+  meta = {
+    description = "Fork of Inconsolata font, with proper support of Cyrillic and Greek";
+    longDescription = ''
+      Inconsolata is one of the most suitable font for programmers created by Raph
+      Levien. Since the original Inconsolata does not contain Cyrillic alphabet,
+      it was slightly inconvenient for not a few programmers from Russia.
+
+      Inconsolata LGC is a modified version of Inconsolata with added the Cyrillic
+      alphabet which directly descends from Inconsolata Hellenic supporting modern
+      Greek.
+
+      Inconsolata LGC is licensed under SIL OFL.
+
+
+      Inconsolata LGC changes:
+      * Cyrillic glyphs added.
+      * Italic and Bold font added.
+
+      Changes inherited from Inconsolata Hellenic:
+      * Greek glyphs.
+
+      Changes inherited from Inconsolata-dz:
+      * Straight quotation marks.
+    '';
+
+    # See `License.txt' for details.
+    license = stdenv.lib.licenses.ofl;
+    homepage = https://github.com/MihailJP/Inconsolata-LGC;
+    maintainers = [
+      stdenv.lib.maintainers.avnik
+    ];
+  };
+}