about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-08-23 23:12:48 +0200
committerGitHub <noreply@github.com>2018-08-23 23:12:48 +0200
commit2df53dee435b446b613f18a92353a05825abdc80 (patch)
tree738cbd23746fcb21f73e10a61ea28d32535ec63e /pkgs/data
parentaf5b528c9577f0fd6ce311fc68727eb1815b1422 (diff)
parentf3139dd378770c2c184763ce5064f9a9236e9c29 (diff)
downloadnixlib-2df53dee435b446b613f18a92353a05825abdc80.tar
nixlib-2df53dee435b446b613f18a92353a05825abdc80.tar.gz
nixlib-2df53dee435b446b613f18a92353a05825abdc80.tar.bz2
nixlib-2df53dee435b446b613f18a92353a05825abdc80.tar.lz
nixlib-2df53dee435b446b613f18a92353a05825abdc80.tar.xz
nixlib-2df53dee435b446b613f18a92353a05825abdc80.tar.zst
nixlib-2df53dee435b446b613f18a92353a05825abdc80.zip
Merge pull request #45358 from leenaars/eunomia
eunomia-font: init at 0.200
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/aileron/default.nix27
-rw-r--r--pkgs/data/fonts/eunomia/default.nix27
-rw-r--r--pkgs/data/fonts/f5_6/default.nix27
-rw-r--r--pkgs/data/fonts/ferrum/default.nix27
-rw-r--r--pkgs/data/fonts/medio/default.nix32
-rw-r--r--pkgs/data/fonts/penna/default.nix32
-rw-r--r--pkgs/data/fonts/route159/default.nix27
-rw-r--r--pkgs/data/fonts/seshat/default.nix37
-rw-r--r--pkgs/data/fonts/tenderness/default.nix27
9 files changed, 263 insertions, 0 deletions
diff --git a/pkgs/data/fonts/aileron/default.nix b/pkgs/data/fonts/aileron/default.nix
new file mode 100644
index 000000000000..52a96f16db0c
--- /dev/null
+++ b/pkgs/data/fonts/aileron/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "102";
+  pname = "aileron";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}.zip";
+  sha256 = "04xnzdy9plzd2p02yq367h37m5ygx0w8cpkdv39cc3754ljlsxim";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/${pname}/";
+    description = "A helvetica font in nine weights";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.cc0;
+  };
+}
diff --git a/pkgs/data/fonts/eunomia/default.nix b/pkgs/data/fonts/eunomia/default.nix
new file mode 100644
index 000000000000..56fa718f8670
--- /dev/null
+++ b/pkgs/data/fonts/eunomia/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "200";
+  pname = "eunomia";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "0lpmczs1d4p9dy4s0dnvv7bl5cd0f6yzyasfrkxij5s86glps38b";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://dotcolon.net/font/eunomia/;
+    description = "A futuristic decorative font.";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}
diff --git a/pkgs/data/fonts/f5_6/default.nix b/pkgs/data/fonts/f5_6/default.nix
new file mode 100644
index 000000000000..25cab717cee9
--- /dev/null
+++ b/pkgs/data/fonts/f5_6/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "110";
+  pname = "f5_6";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "04p6lccd26rhjbpq3ddxi5vkk3lk8lqbpnk8lakjzixp3fgdqpp4";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/${pname}/";
+    description = "A weighted decorative font.";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}
diff --git a/pkgs/data/fonts/ferrum/default.nix b/pkgs/data/fonts/ferrum/default.nix
new file mode 100644
index 000000000000..bbe185bd8486
--- /dev/null
+++ b/pkgs/data/fonts/ferrum/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "200";
+  pname = "ferrum";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}.zip";
+  sha256 = "1w1b3ch7ik4264f05lxms01ls0aargvlx770a9szm682dfmizn8w";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/${pname}/";
+    description = "A decorative font.";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.cc0;
+  };
+}
diff --git a/pkgs/data/fonts/medio/default.nix b/pkgs/data/fonts/medio/default.nix
new file mode 100644
index 000000000000..8b484b3b5efd
--- /dev/null
+++ b/pkgs/data/fonts/medio/default.nix
@@ -0,0 +1,32 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "200";
+  pname = "medio";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}.zip";
+  sha256 = "0gxcmhjlsh2pzsmj78vw4v935ax7hfk533ddlhfhfma52zyxyh7x";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/{pname}/";
+    description = "Serif font designed by Sora Sagano";
+    longDescription = ''
+      Medio is a serif font designed by Sora Sagano, based roughly
+      on the proportions of the font Tenderness (from the same designer),
+      but with hairline serifs in the style of a Didone.
+    '';
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.cc0;
+  };
+}
diff --git a/pkgs/data/fonts/penna/default.nix b/pkgs/data/fonts/penna/default.nix
new file mode 100644
index 000000000000..893553a62ce2
--- /dev/null
+++ b/pkgs/data/fonts/penna/default.nix
@@ -0,0 +1,32 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "10";
+  pname = "penna";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}.zip";
+  sha256 = "0hk15yndm56l6rbdykpkry2flffx0567mgjcqcnsx1iyzwwla5km";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/{pname}/";
+    description = "Geometric sans serif designed by Sora Sagano";
+    longDescription = ''
+     Penna is a geometric sans serif designed by Sora Sagano,
+     with outsized counters in the uppercase and a lowercase
+     with a small x-height.
+    '';
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.cc0;
+  };
+}
diff --git a/pkgs/data/fonts/route159/default.nix b/pkgs/data/fonts/route159/default.nix
new file mode 100644
index 000000000000..7e2480a77dc5
--- /dev/null
+++ b/pkgs/data/fonts/route159/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "1";
+  minorVersion = "10";
+  pname = "route159";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "1nv5csg73arvvwpac7ylh4j9n0s3qp79rbv2s4jvs2bf6gqhsq7h";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/{pname}/";
+    description = "A weighted sans serif font";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}
diff --git a/pkgs/data/fonts/seshat/default.nix b/pkgs/data/fonts/seshat/default.nix
new file mode 100644
index 000000000000..36e4f2fa10ff
--- /dev/null
+++ b/pkgs/data/fonts/seshat/default.nix
@@ -0,0 +1,37 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "100";
+  pname = "seshat";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}.zip";
+  sha256 = "1zzgc2d0jrris92p3irmxjhdq8aj99alz0z7dlz25qf37lcilrir";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/{pname}/";
+    description = "Roman body font designed for main text by Sora Sagano";
+    longDescription = ''
+      Seshat is a Roman body font designed for the main text. By
+      referring to the classical balance, we changed some lines by
+      omitting part of the lines such as "A" and "n".
+
+      Also, by attaching the strength of the thickness like Optima
+      to the main drawing, it makes it more sharp design.
+
+      It incorporates symbols and ligatures used in the European region.
+    '';
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.cc0;
+  };
+}
diff --git a/pkgs/data/fonts/tenderness/default.nix b/pkgs/data/fonts/tenderness/default.nix
new file mode 100644
index 000000000000..29682cc12990
--- /dev/null
+++ b/pkgs/data/fonts/tenderness/default.nix
@@ -0,0 +1,27 @@
+{ stdenv,  fetchzip }:
+
+let
+  majorVersion = "0";
+  minorVersion = "601";
+  pname = "tenderness";
+in
+
+fetchzip rec {
+  name = "${pname}-font-${majorVersion}.${minorVersion}";
+
+  url = "http://dotcolon.net/DL/font/${pname}_${majorVersion}${minorVersion}.zip";
+  sha256 = "0d88l5mzq0k63zsmb8d5w3hfqxy04vpv4j0j8nmj1xv6kikhhybh";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts/opentype/${pname}
+    unzip -j $downloadedFile \*.otf  -d $out/share/fonts/opentype/${pname}
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://dotcolon.net/font/${pname}/";
+    description = "Serif font designed by Sora Sagano with old-style figures";
+    platforms = platforms.all;
+    maintainers = with maintainers; [ leenaars ];
+    license = licenses.ofl;
+  };
+}