about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-07-18 13:40:47 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-07-20 11:55:46 +0200
commit1681718e2fd81c2613604df0a3fbb259bf213ceb (patch)
treebb067e3e06d6968d98348e534971565bfa9023d0 /pkgs/data
parent55120ac4cb6ee9c051006508390c48649301e6db (diff)
downloadnixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar.gz
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar.bz2
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar.lz
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar.xz
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.tar.zst
nixlib-1681718e2fd81c2613604df0a3fbb259bf213ceb.zip
google-fonts: Turn into a fixed-output derivation
Also remove the executable bit from some fonts, and don't build on
Hydra because this package is huge.
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/google-fonts/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/pkgs/data/fonts/google-fonts/default.nix b/pkgs/data/fonts/google-fonts/default.nix
index e4c655877c8b..0e41cd4e6b71 100644
--- a/pkgs/data/fonts/google-fonts/default.nix
+++ b/pkgs/data/fonts/google-fonts/default.nix
@@ -12,15 +12,22 @@ stdenv.mkDerivation rec {
   phases = [ "unpackPhase" "installPhase" ];
 
   installPhase = ''
-    mkdir -p $out/share/fonts/truetype
-    find . -name "*.ttf" -exec cp -v {} $out/share/fonts/truetype \;
+    dest=$out/share/fonts/truetype
+    mkdir -p $dest
+    find . -name "*.ttf" -exec cp -v {} $dest \;
+    chmod -x $dest/*.ttf
   '';
 
+  outputHashAlgo = "sha256";
+  outputHashMode = "recursive";
+  outputHash = "0q03gg0sh2mljlbmhamnxz28d13znh9dzca84p554s7pwg6z4wca";
+
   meta = with stdenv.lib; {
     homepage = https://www.google.com/fontsl;
     description = "Font files available from Google Font";
     license = with licenses; [ asl20 ofl ufl ];
     platforms = platforms.all;
+    hydraPlatforms = [];
     maintainers = with maintainers; [ manveru ];
   };
 }