about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-01 11:25:41 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-01 11:25:41 +0200
commit06fc1ec34dbae8bba4673475e64a8241026089f6 (patch)
tree3e70796a291acc704ef5382f5af4866cab64e537 /pkgs/data
parent89f8af55f11b01e68cbfc6d10537413140261721 (diff)
parentce623950ada9e1ef721760f05b9e3a14604fd764 (diff)
downloadnixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar.gz
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar.bz2
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar.lz
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar.xz
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.tar.zst
nixlib-06fc1ec34dbae8bba4673475e64a8241026089f6.zip
Merge remote-tracking branch 'origin/master' into staging
Conflicts:
	pkgs/servers/serfdom/default.nix
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/anonymous-pro/default.nix3
-rw-r--r--pkgs/data/fonts/ipafont/default.nix33
-rw-r--r--pkgs/data/fonts/kochi-substitute-naga10/default.nix34
-rw-r--r--pkgs/data/fonts/kochi-substitute/default.nix43
4 files changed, 113 insertions, 0 deletions
diff --git a/pkgs/data/fonts/anonymous-pro/default.nix b/pkgs/data/fonts/anonymous-pro/default.nix
index 21a1c9bf5c85..cca775d941e1 100644
--- a/pkgs/data/fonts/anonymous-pro/default.nix
+++ b/pkgs/data/fonts/anonymous-pro/default.nix
@@ -40,6 +40,9 @@ rec {
     ];
     platforms = with a.lib.platforms;
       all;
+    license = with a.lib.licenses; ofl;
+    hydraPlatforms = [];
+    homepage = "http://www.marksimonson.com/fonts/view/anonymous-pro";
   };
   passthru = {
     updateInfo = {
diff --git a/pkgs/data/fonts/ipafont/default.nix b/pkgs/data/fonts/ipafont/default.nix
new file mode 100644
index 000000000000..91bf95d1ea25
--- /dev/null
+++ b/pkgs/data/fonts/ipafont/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation {
+  name = "ipafont-003.03";
+
+  src = fetchurl {
+    url = "http://ipafont.ipa.go.jp/ipafont/IPAfont00303.php";
+    sha256 = "f755ed79a4b8e715bed2f05a189172138aedf93db0f465b4e20c344a02766fe5";
+  };
+
+  buildInputs = [ unzip ];
+
+  unpackPhase = ''
+    unzip $src
+  '';
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/opentype
+    cp ./IPAfont00303/*.ttf $out/share/fonts/opentype/
+  '';
+
+  meta = {
+    description = "Japanese font package with Mincho and Gothic fonts";
+    longDescription = ''
+      IPAFont is a Japanese font developed by the Information-technology
+      Promotion Agency of Japan. It provides both Mincho and Gothic fonts,
+      suitable for both display and printing.
+    '';
+    homepage = http://ipafont.ipa.go.jp/ipafont/;
+    license = stdenv.lib.licenses.ipa;
+    maintainers = [ stdenv.lib.maintainers.auntie ];
+  };
+}
diff --git a/pkgs/data/fonts/kochi-substitute-naga10/default.nix b/pkgs/data/fonts/kochi-substitute-naga10/default.nix
new file mode 100644
index 000000000000..98ab8a3bcac5
--- /dev/null
+++ b/pkgs/data/fonts/kochi-substitute-naga10/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchurl }:
+
+let version = "20030809";
+in
+stdenv.mkDerivation {
+  name = "kochi-substitute-naga10-${version}";
+
+  src = fetchurl {
+    url = "mirror://sourceforgejp/efont/5411/kochi-substitute-${version}.tar.bz2";
+    sha256 = "f4d69b24538833bf7e2c4de5e01713b3f1440960a6cc2a5993cb3c68cd23148c";
+  };
+
+  sourceRoot = "kochi-substitute-${version}";
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp ./kochi-gothic-subst.ttf $out/share/fonts/truetype/kochi-gothic-subst-naga10.ttf
+    cp ./kochi-mincho-subst.ttf $out/share/fonts/truetype/kochi-mincho-subst-naga10.ttf
+  '';
+
+  meta = {
+    description = "Japanese font, non-free replacement for MS Gothic and MS Mincho.";
+    longDescription = ''
+      Kochi Gothic and Kochi Mincho were developed as free replacements for the
+      MS Gothic and MS Mincho fonts from Microsoft. This version of the fonts
+      includes some non-free glyphs from the naga10 font, which stipulate that
+      this font may not be sold commercially. See kochi-substitute for the free
+      Debian version.
+    '';
+    homepage = http://sourceforge.jp/projects/efont/;
+    license = stdenv.lib.licenses.unfreeRedistributable;
+    maintainers = [ stdenv.lib.maintainers.auntie ];
+  };
+}
diff --git a/pkgs/data/fonts/kochi-substitute/default.nix b/pkgs/data/fonts/kochi-substitute/default.nix
new file mode 100644
index 000000000000..dec20fd51000
--- /dev/null
+++ b/pkgs/data/fonts/kochi-substitute/default.nix
@@ -0,0 +1,43 @@
+{ stdenv, fetchurl, dpkg }:
+
+let version = "20030809";
+in
+stdenv.mkDerivation {
+  name = "kochi-substitute-${version}";
+
+  src = fetchurl {
+    url = "mirror://debian/pool/main/t/ttf-kochi/ttf-kochi-gothic_${version}-15_all.deb";
+    sha256 = "6e2311cd8e880a9328e4d3eef34a1c1f024fc87fba0dce177a0e1584a7360fea";
+  };
+
+  src2 = fetchurl {
+    url = "mirror://debian/pool/main/t/ttf-kochi/ttf-kochi-mincho_${version}-15_all.deb";
+    sha256 = "91ce6c993a3a0f77ed85db76f62ce18632b4c0cbd8f864676359a17ae5e6fa3c";
+  };
+
+  buildInputs = [ dpkg ];
+
+  unpackCmd = ''
+    dpkg-deb --fsys-tarfile $src | tar xf - ./usr/share/fonts/truetype/kochi/kochi-gothic-subst.ttf
+    dpkg-deb --fsys-tarfile $src2 | tar xf - ./usr/share/fonts/truetype/kochi/kochi-mincho-subst.ttf
+  '';
+
+  installPhase = ''
+    mkdir -p $out/share/fonts/truetype
+    cp ./share/fonts/truetype/kochi/kochi-gothic-subst.ttf $out/share/fonts/truetype/
+    cp ./share/fonts/truetype/kochi/kochi-mincho-subst.ttf $out/share/fonts/truetype/
+  '';
+
+  meta = {
+    description = "Japanese font, a free replacement for MS Gothic and MS Mincho.";
+    longDescription = ''
+      Kochi Gothic and Kochi Mincho were developed as free replacements for the
+      MS Gothic and MS Mincho fonts from Microsoft. These are the Debian
+      versions of the fonts, which remove some non-free glyphs that were added
+      from the naga10 font.
+    '';
+    homepage = http://sourceforge.jp/projects/efont/;
+    license = stdenv.lib.licenses.wadalab;
+    maintainers = [ stdenv.lib.maintainers.auntie ];
+  };
+}