about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorMaciej Krüger <mkg20001@gmail.com>2024-02-04 21:52:17 +0100
committerMaciej Krüger <mkg20001@gmail.com>2024-02-08 10:18:34 +0100
commitfb988d2f7a085c849ef3cbdf16af3641c6896304 (patch)
treefb9f2b8b4088fd249b0222612421ed183d0c3a1b /pkgs/by-name
parent763868f445839c7a600757ff31f06de16b6cfe09 (diff)
downloadnixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar.gz
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar.bz2
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar.lz
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar.xz
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.tar.zst
nixlib-fb988d2f7a085c849ef3cbdf16af3641c6896304.zip
oil: rename to oil-python
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/oi/oil-python/package.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/pkgs/by-name/oi/oil-python/package.nix b/pkgs/by-name/oi/oil-python/package.nix
new file mode 100644
index 000000000000..0c5cf044e09a
--- /dev/null
+++ b/pkgs/by-name/oi/oil-python/package.nix
@@ -0,0 +1,58 @@
+{ stdenv, lib, fetchurl, symlinkJoin, withReadline ? true, readline }:
+
+let
+  readline-all = symlinkJoin {
+    name = "readline-all"; paths = [ readline readline.dev ];
+  };
+in
+stdenv.mkDerivation rec {
+  pname = "oil";
+  version = "0.20.0";
+
+  src = fetchurl {
+    url = "https://www.oilshell.org/download/oil-${version}.tar.xz";
+    hash = "sha256-QrhfUru6Sju44W8j/DlMQwK8/ZY48GfwHDfSPy7kSaA=";
+  };
+
+  postPatch = ''
+    patchShebangs build
+  '';
+
+  preInstall = ''
+    mkdir -p $out/bin
+  '';
+
+  strictDeps = true;
+  buildInputs = lib.optional withReadline readline;
+  # As of 0.20.0 the build generates an error on MacOS (using clang version 16.0.6 in the builder),
+  # whereas running it outside of Nix with clang version 15.0.0 generates just a warning. The shell seems to
+  # work just fine though, so we disable the error here.
+  env.NIX_CFLAGS_COMPILE = lib.optionalString stdenv.cc.isClang "-Wno-error=incompatible-function-pointer-types";
+  configureFlags = [
+    "--datarootdir=${placeholder "out"}"
+  ] ++ lib.optionals withReadline [
+    "--with-readline"
+    "--readline=${readline-all}"
+  ];
+
+  # Stripping breaks the bundles by removing the zip file from the end.
+  dontStrip = true;
+
+  meta = {
+    description = "A new unix shell - Old python build";
+    homepage = "https://www.oilshell.org/";
+
+    license = with lib.licenses; [
+      psfl # Includes a portion of the python interpreter and standard library
+      asl20 # Licence for Oil itself
+    ];
+
+    platforms = lib.platforms.all;
+    maintainers = with lib.maintainers; [ lheckemann alva ];
+    changelog = "https://www.oilshell.org/release/${version}/changelog.html";
+  };
+
+  passthru = {
+    shellPath = "/bin/osh";
+  };
+}