about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorD3vil0p3r <vozaanthony@gmail.com>2024-02-10 21:39:42 +0100
committerD3vil0p3r <vozaanthony@gmail.com>2024-02-10 21:39:42 +0100
commitd87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c (patch)
treeec4161ae44f2103616f0c87db277e5fde6b83453 /pkgs/by-name
parentb491a9522516a4d43f9f1aed542be96de1a74a0d (diff)
downloadnixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar.gz
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar.bz2
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar.lz
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar.xz
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.tar.zst
nixlib-d87e3ab3a3724e71a7ef6b82e05691dd3e0f9f8c.zip
Package migration to by-name
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/wi/wifite2/package.nix81
1 files changed, 81 insertions, 0 deletions
diff --git a/pkgs/by-name/wi/wifite2/package.nix b/pkgs/by-name/wi/wifite2/package.nix
new file mode 100644
index 000000000000..250caa468ba5
--- /dev/null
+++ b/pkgs/by-name/wi/wifite2/package.nix
@@ -0,0 +1,81 @@
+{ lib
+, fetchFromGitHub
+, fetchpatch
+, python3
+, python3Packages
+, wirelesstools
+, aircrack-ng
+, wireshark-cli
+, reaverwps-t6x
+, cowpatty
+, hashcat
+, hcxtools
+, hcxdumptool
+, which
+, bully
+, pixiewps
+, john
+, iw
+, macchanger
+}:
+
+let
+  pythonDependencies = with python3Packages; [
+    chardet
+    scapy
+  ];
+in
+python3.pkgs.buildPythonApplication rec {
+  pname = "wifite2";
+  version = "2.7.0";
+
+  src = fetchFromGitHub {
+    owner = "kimocoder";
+    repo = "wifite2";
+    rev = version;
+    hash = "sha256-G2AKKZUDS2UQm95TEhGJIucyMRcm7oL0d3J8uduEQhw=";
+  };
+
+  patches = [
+    (fetchpatch {
+      url = "https://salsa.debian.org/pkg-security-team/wifite/raw/debian/2.7.0-1/debian/patches/Disable-aircrack-failing-test.patch";
+      hash = "sha256-BUAowBajfnZ1x6Z3Ce3L0rAERv7v/KrdHcdvKxTxSrM=";
+    })
+    (fetchpatch {
+      url = "https://salsa.debian.org/pkg-security-team/wifite/raw/debian/2.7.0-1/debian/patches/Disable-two-failing-tests.patch";
+      hash = "sha256-wCwfNkF/GvOU5FWPmQ3dJ4Txthz9T9TO2xhSL5vllQc=";
+    })
+    (fetchpatch {
+      url = "https://salsa.debian.org/pkg-security-team/wifite/raw/debian/2.7.0-1/debian/patches/fix-for-new-which.patch";
+      hash = "sha256-8xs+O2ILSRcvsw2pyx2gEBFHdduoI+xmUvDBchKz2Qs=";
+    })
+  ];
+
+  propagatedBuildInputs = [
+    aircrack-ng
+    wireshark-cli
+    reaverwps-t6x
+    cowpatty
+    hashcat
+    hcxtools
+    hcxdumptool
+    wirelesstools
+    which
+    bully
+    pixiewps
+    john
+    iw
+    macchanger
+  ] ++ pythonDependencies;
+
+  nativeCheckInputs = propagatedBuildInputs ++ [ python3.pkgs.unittestCheckHook ];
+
+  meta = with lib; {
+    homepage = "https://github.com/kimocoder/wifite2";
+    description = "Rewrite of the popular wireless network auditor, wifite";
+    mainProgram = "wifite";
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ lassulus danielfullmer d3vil0p3r ];
+  };
+}