about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorhappysalada <raphael@megzari.com>2023-11-21 09:36:26 +0100
committerYt <happysalada@tuta.io>2023-11-22 03:04:20 +0000
commitd7376bc88ee310a1b4ce8781fab34b1830a117e2 (patch)
tree00c11a5d4c3214b67a4e0586ecebdef9b59a9133 /pkgs/by-name
parent955f2d39ec08edb4ba3cfbfa7253e19aad45d3d8 (diff)
downloadnixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar.gz
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar.bz2
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar.lz
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar.xz
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.tar.zst
nixlib-d7376bc88ee310a1b4ce8781fab34b1830a117e2.zip
fangfrisch: init at 1.6.1
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/fa/fangfrisch/package.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/by-name/fa/fangfrisch/package.nix b/pkgs/by-name/fa/fangfrisch/package.nix
new file mode 100644
index 000000000000..f3a6c466ac09
--- /dev/null
+++ b/pkgs/by-name/fa/fangfrisch/package.nix
@@ -0,0 +1,40 @@
+{ lib
+, python3
+, fetchFromGitHub
+}:
+let
+  version = "1.6.1";
+in
+python3.pkgs.buildPythonApplication {
+  pname = "fangfrisch";
+  inherit version;
+  pyproject = true;
+
+  src = fetchFromGitHub {
+    owner = "rseichter";
+    repo = "fangfrisch";
+    rev = version;
+    hash = "sha256-yXXzwN0BI//NqpNNmKIhwFv3hDwNZLl1K81hUD/tCrQ=";
+  };
+
+  nativeBuildInputs = [
+    python3.pkgs.setuptools
+    python3.pkgs.wheel
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
+    requests
+    sqlalchemy
+  ];
+
+  pythonImportsCheck = [ "fangfrisch" ];
+
+  meta = with lib; {
+    description = "Update and verify unofficial Clam Anti-Virus signatures";
+    homepage = "https://github.com/rseichter/fangfrisch";
+    changelog = "https://github.com/rseichter/fangfrisch/blob/${version}/CHANGELOG.rst";
+    license = licenses.gpl3Only;
+    maintainers = with maintainers; [ happysalada ];
+    mainProgram = "fangfrisch";
+  };
+}