about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authoréclairevoyant <848000+eclairevoyant@users.noreply.github.com>2023-10-16 19:57:15 -0400
committeréclairevoyant <848000+eclairevoyant@users.noreply.github.com>2023-10-16 19:57:50 -0400
commitd1d5ce7bd431c027e56c90d4a2c2300570271ae1 (patch)
tree6efc725b19af6417bda783feacb5ae697692c13b /pkgs/by-name
parent2dc99487cabf2b485158d8b9e74b855a2ab1052a (diff)
downloadnixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar.gz
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar.bz2
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar.lz
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar.xz
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.tar.zst
nixlib-d1d5ce7bd431c027e56c90d4a2c2300570271ae1.zip
swipe-guess: init at 0.2.1
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/sw/swipe-guess/package.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/by-name/sw/swipe-guess/package.nix b/pkgs/by-name/sw/swipe-guess/package.nix
new file mode 100644
index 000000000000..2f6d5f8fe9a5
--- /dev/null
+++ b/pkgs/by-name/sw/swipe-guess/package.nix
@@ -0,0 +1,39 @@
+{ lib
+, stdenv
+, fetchFromSourcehut
+}:
+
+stdenv.mkDerivation rec {
+  pname = "swipe-guess";
+  version = "0.2.1";
+
+  src = fetchFromSourcehut {
+    owner = "~earboxer";
+    repo = "swipeGuess";
+    rev = "v${version}";
+    hash = "sha256-8bPsnqjLeeZ7btTre9j1T93VWY9+FdBdJdxyvBVt34s=";
+  };
+
+  dontConfigure = true;
+
+  buildPhase = ''
+    runHook preBuild
+
+    ${lib.getExe stdenv.cc} swipeGuess.c -o swipeGuess
+
+    runHook postBuild
+  '';
+
+  postInstall = ''
+    install -Dm555 swipeGuess -t $out/bin
+  '';
+
+  meta = {
+    description = "Completion plugin for touchscreen-keyboards on mobile devices";
+    homepage = "https://git.sr.ht/~earboxer/swipeGuess/";
+    license = lib.licenses.agpl3Only;
+    mainProgram = "swipeGuess";
+    maintainers = with lib.maintainers; [ eclairevoyant ];
+    platforms = lib.platforms.all;
+  };
+}