about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorPol Dellaiera <pol.dellaiera@protonmail.com>2024-03-13 13:52:37 +0100
committerGitHub <noreply@github.com>2024-03-13 13:52:37 +0100
commitd13d07454bc358624db4009d1ded830a48a6e0bf (patch)
tree6a6811a61189c49285b1e2c9d239a8571176bfae /pkgs/by-name
parent075fa043f42b8d35125742d387f81f1655ee865a (diff)
parent81401567b7101e99fa5c67a4fba61d2329a38aa3 (diff)
downloadnixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar.gz
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar.bz2
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar.lz
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar.xz
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.tar.zst
nixlib-d13d07454bc358624db4009d1ded830a48a6e0bf.zip
Merge pull request #295281 from almini/mbpoll
mbpoll: init at 1.5
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/mb/mbpoll/package.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/by-name/mb/mbpoll/package.nix b/pkgs/by-name/mb/mbpoll/package.nix
new file mode 100644
index 000000000000..6a972506bfca
--- /dev/null
+++ b/pkgs/by-name/mb/mbpoll/package.nix
@@ -0,0 +1,30 @@
+{ lib
+, stdenv
+, cmake
+, pkg-config
+, fetchFromGitHub
+, libmodbus
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+  pname = "mbpoll";
+  version = "1.5";
+
+  src = fetchFromGitHub {
+    owner = "epsilonrt";
+    repo = "mbpoll";
+    rev = "v${finalAttrs.version}";
+    hash = "sha256-rHjLDgfKtpREemttWt0pr7VtBjwZCSplUR4OWNBVW0c=";
+  };
+
+  buildInputs = [ libmodbus ];
+  nativeBuildInputs = [ cmake pkg-config ];
+
+  meta = with lib; {
+    description = "Command line utility to communicate with ModBus slave (RTU or TCP)";
+    homepage = "https://epsilonrt.fr";
+    license = licenses.gpl3;
+    mainProgram = "mbpoll";
+    platforms = platforms.linux;
+  };
+})