about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorJeremy Fleischman <jeremyfleischman@gmail.com>2024-02-26 20:25:56 -0800
committerJeremy Fleischman <jeremyfleischman@gmail.com>2024-03-09 20:12:45 -0800
commit9f7c981becdaf5db54b43a2ac22a70feee0162c8 (patch)
tree2d53f466dee23a3fca89f0db161152b330407909 /pkgs/by-name
parent860a2c5921f100906d8c711d29a5f62bc283b588 (diff)
downloadnixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar.gz
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar.bz2
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar.lz
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar.xz
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.tar.zst
nixlib-9f7c981becdaf5db54b43a2ac22a70feee0162c8.zip
kikit: 1.4.0 -> 1.5.0
This includes support for KiCad 8 (see complete changelog
[here](https://github.com/yaqwsx/KiKit/releases/tag/v1.5.0)), which should unblock
https://github.com/NixOS/nixpkgs/pull/291134.

With this upgrade, a test started failing:

    $ nix build .#kikit
    ...
    kikit> not ok 40 Steel stencils
    kikit> # (in test file /build/source/test/system/stencil.bats, line 6)
    kikit> #   `kikit stencil create  --jigsize 60 60 $RES/conn.kicad_pcb steelStencil' failed
    kikit> # 04:32:16: Error: Directory '/homeless-shelter' couldn't be created (error 13: Permission denied)
    kikit> # An error occurred: OpenSCAD is not available.
    kikit> # Did you install it? Program `openscad` has to be in PATH
    kikit> # No output files produced
    kikit> not ok 41 Steel stencils with cutout
    kikit> # (in test file /build/source/test/system/stencil.bats, line 10)
    kikit> #   `kikit stencil create  --jigsize 60 60 --cutout J4 $RES/conn.kicad_pcb steelStencil' failed
    kikit> # 04:32:17: Error: Directory '/homeless-shelter' couldn't be created (error 13: Permission denied)
    kikit> # An error occurred: OpenSCAD is not available.
    kikit> # Did you install it? Program `openscad` has to be in PATH
    kikit> # No output files produced
    kikit> not ok 42 Printed stencils
    kikit> # (in test file /build/source/test/system/stencil.bats, line 14)
    kikit> #   `kikit stencil createprinted \' failed
    kikit> # 04:32:17: Error: Directory '/homeless-shelter' couldn't be created (error 13: Permission denied)
    kikit> # An error occurred: OpenSCAD is not available.
    kikit> # Did you install it? Program `openscad` has to be in PATH
    kikit> # No output files produced
    kikit> make: *** [Makefile:40: test-system] Error 1
    kikit> /nix/store/3qnm3nwjajgqa771dmi2dnwxrw0kzq5m-stdenv-linux/setup: line 131: pop_var_context: head of shell_variables not a function context
    error: builder for '/nix/store/f3klmz0qvi6yr3qfy7cww434f2z4kjx5-kikit-1.5.0.drv' failed with exit code 2;

This is failing in some pretty old kikit code, so I think this is just
failing due to kikit now having more complete code coverage. While
researching this, I discovered kikit's documentation about [optional
dependencies], which I suppose we don't have good support for right now.
Rather than invent a new option for that, I've opted to preserve the
existing behavior and just do the bare minimum to keep the build
passing.

[optional dependencies]: https://github.com/yaqwsx/KiKit/blob/v1.5.0/docs/installation/intro.md#optional-dependencies
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/ki/kikit/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/by-name/ki/kikit/default.nix b/pkgs/by-name/ki/kikit/default.nix
index e34f12652ede..e8356fd0a0ff 100644
--- a/pkgs/by-name/ki/kikit/default.nix
+++ b/pkgs/by-name/ki/kikit/default.nix
@@ -10,6 +10,7 @@
 , numpy
 , click
 , markdown2
+, openscad
 , pytestCheckHook
 , commentjson
 , wxpython
@@ -23,7 +24,7 @@ let
 in
 buildPythonApplication rec {
   pname = "kikit";
-  version = "1.4.0";
+  version = "1.5.0";
   format = "setuptools";
 
   disabled = pythonOlder "3.7";
@@ -32,7 +33,7 @@ buildPythonApplication rec {
     owner = "yaqwsx";
     repo = "KiKit";
     rev = "refs/tags/v${version}";
-    hash = "sha256-88/1bL3MtawR/8P8U1jHatMbq+JxF1qb+plH3rYh1qU=";
+    hash = "sha256-f8FB6EEy9Ch4LcMKd9PADXV9QrSb7e22Ui86G6AnQKE=";
   };
 
   propagatedBuildInputs = [
@@ -40,6 +41,9 @@ buildPythonApplication rec {
     numpy
     click
     markdown2
+    # OpenSCAD is an optional dependency (see
+    # https://github.com/yaqwsx/KiKit/blob/v1.5.0/docs/installation/intro.md#optional-dependencies).
+    openscad
     commentjson
     # https://github.com/yaqwsx/KiKit/issues/575
     wxpython