about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2023-12-14 11:38:52 +0100
committerFabian Affolter <mail@fabian-affolter.ch>2023-12-14 11:38:52 +0100
commit9076c9b8ec7a98dfc74b925093616fa8a94bfd14 (patch)
tree07deb504f10401877753fe1ecb7d2521e7d189da /pkgs/by-name
parentb45e6ec4283be8fd92a442fe2ddf85cc64c03343 (diff)
downloadnixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar.gz
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar.bz2
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar.lz
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar.xz
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.tar.zst
nixlib-9076c9b8ec7a98dfc74b925093616fa8a94bfd14.zip
dep-scan: init at 5.0.2
Security and risk audit tool based on known vulnerabilities,
advisories, and license limitations for project dependencies

https://github.com/owasp-dep-scan/dep-scan
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/de/dep-scan/package.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/pkgs/by-name/de/dep-scan/package.nix b/pkgs/by-name/de/dep-scan/package.nix
new file mode 100644
index 000000000000..48ba5c4c51ae
--- /dev/null
+++ b/pkgs/by-name/de/dep-scan/package.nix
@@ -0,0 +1,66 @@
+{ lib
+, python3
+, fetchFromGitHub
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "dep-scan";
+  version = "5.0.2";
+  pyproject = true;
+
+  src = fetchFromGitHub {
+    owner = "owasp-dep-scan";
+    repo = "dep-scan";
+    rev = "refs/tags/v${version}";
+    hash = "sha256-qiJyGBGxznNF4LNG9fbmjG7wX0odhrUO2LxOWABtLQA=";
+  };
+
+  postPatch = ''
+    substituteInPlace pytest.ini \
+      --replace " --cov-append --cov-report term --cov depscan" ""
+  '';
+
+  nativeBuildInputs = with python3.pkgs; [
+    setuptools
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
+    appthreat-vulnerability-db
+    defusedxml
+    jinja2
+    oras
+    pdfkit
+    pygithub
+    pyyaml
+    quart
+    rich
+    toml
+  ];
+
+  nativeCheckInputs = with python3.pkgs; [
+    httpretty
+    pytestCheckHook
+  ];
+
+  pythonImportsCheck = [
+    "depscan"
+  ];
+
+  preCheck = ''
+    export HOME=$(mktemp -d)
+  '';
+
+  disabledTests = [
+    # Test is not present
+    "test_query_metadata2"
+  ];
+
+  meta = with lib; {
+    description = "Security and risk audit tool based on known vulnerabilities, advisories, and license limitations for project dependencies";
+    homepage = "https://github.com/owasp-dep-scan/dep-scan";
+    changelog = "https://github.com/owasp-dep-scan/dep-scan/releases/tag/v${version}";
+    license = licenses.mit;
+    maintainers = with maintainers; [ fab ];
+    mainProgram = "dep-scan";
+  };
+}