about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorPol Dellaiera <pol.dellaiera@protonmail.com>2024-03-23 19:42:40 +0100
committerGitHub <noreply@github.com>2024-03-23 19:42:40 +0100
commit8e8752b3f0c329c9464dc5727224f8f7578e458b (patch)
tree1ce4429f7e5a6fd70676e99ce603131b49e24760 /pkgs/by-name
parent744a81271f9f1c9aa080a734e92a2de94c14b053 (diff)
parent7b058b7d0e9b934a8d9614453a229010276cdf5f (diff)
downloadnixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar.gz
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar.bz2
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar.lz
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar.xz
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.tar.zst
nixlib-8e8752b3f0c329c9464dc5727224f8f7578e458b.zip
Merge pull request #297790 from Guanran928/spotube
spotube: use `makeBinaryWrapper`
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/sp/spotube/package.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/by-name/sp/spotube/package.nix b/pkgs/by-name/sp/spotube/package.nix
index c5b29a43187e..57411c32068f 100644
--- a/pkgs/by-name/sp/spotube/package.nix
+++ b/pkgs/by-name/sp/spotube/package.nix
@@ -4,6 +4,7 @@
 
 , autoPatchelfHook
 , dpkg
+, makeBinaryWrapper
 , makeWrapper
 , undmg
 , wrapGAppsHook
@@ -51,13 +52,13 @@ let
 
     sourceRoot = ".";
 
-    nativeBuildInputs = [ undmg ];
+    nativeBuildInputs = [ undmg makeBinaryWrapper ];
 
     installPhase = ''
       runHook preInstall
       mkdir -p $out/Applications $out/bin
       cp -r spotube.app $out/Applications
-      ln -s $out/Applications/spotube.app/Contents/MacOS/spotube $out/bin/spotube
+      makeBinaryWrapper $out/Applications/spotube.app/Contents/MacOS/spotube $out/bin/spotube
       runHook postInstall
     '';
   };